Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED LSI SAS 9207-8e HBA only works with one drive

Logikgear

Member
Joined
Feb 22, 2016
Messages
43
So I have run into a wall. I picked up an LSI SAS 9207-8e HBA off Amazon along with a CableCreation Mini SAS 36Pin (SFF-8088) Male to 4 SATA 7Pin Female Cable, Mini SAS Host/Controller to 4 SATA Target/Backplane cable. I'm using 4 WD 500GB Re HDDs inside an iStarUSA Group BPU-350SATA-RED hot-swap caddy for testing. All of this is connected to a Supermicro X9SRA motherboard with an e5-2620 and 128GB of RAM. FreeNAS-11.2-RELEASE is installed on a Samsun 840 SSD connected to the onboard SATA controller. When I try and boot the system with only one drive connected to the HBA it will boot into FreeNAS (or Win10) without any problems. I can also access the SAS utility in the LSI BIOS to access the HBAs settings. Now if I connect another drive FreeNAS won't post and I get some errors. (photo below) Also, I'm not able to get access to the HBA in the SAS utility. It stops at "reading non-volatile settings" and never moves on.
Dxj9sEnV4AAjmzl.jpg
I have connected one drive at a time to each of the SATA connectors on the break out cable and all channels work. I have tried flashing the BIOS and Firmware of the card with the downloads on Broadcom's web site.
Current firmware is Version no: 20.00.06.00
Current BIOS is Version no: 7.39.02.00

At this point, I have reached out the seller on Amazon about any other troubleshooting steps or a replacement HBA. But, I was hoping maybe someone here would have an idea or has run into this before. I hope I'm just doing something wrong.
 

Logikgear

Member
Joined
Feb 22, 2016
Messages
43
Were you able to resolve this?
Looks to be.

Update: The Amazon Reseller got back to me and it looks like they had received a bad batch from their supplier. They found several with similar problems. They are shipping me a replacement. I will test it and update again. But this appears to be faulty hardware.
 

Logikgear

Member
Joined
Feb 22, 2016
Messages
43
Final update:

The Amazon seller sent me a replacement HBA and it works perfectly. 100% hardware fault.
 
Top