Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Issue with Character Encoding When Mounting Windows Share to FreeNAS 11 Server

Status
Not open for further replies.

jsmith65

Neophyte
Joined
Jun 8, 2018
Messages
5
So I don't have enough storage in my FreeNAS 11 server yet to transfer all my media content onto it yet. However, I'm wanting to run my Plex server on my Freenas server instead of on my Windows desktop. My plan to do this was to mount my Windows shares to Freenas and then add them to the Plex jail. This actually works great except for one thing. For some reason certain special characters won't show up properly in the smb mount in FreeNAS. It just shows a little question mark inside of a diamond character inside of Plex, and it just shows a question mark where the special character should be when using the ls command via ssh. I used this command to mount the Windows share in FreeNAS:

mount_smbfs -I <ip_address> //<host>/Movies /mnt/movies

Example of messed up filenames:
"Amélie" looks like this in on FreeNAS: Am?lie

I've tried to change the encoding using many variations of the -E parameter for mount_smbfs (-E utf-8:cp852 or cp866 or 852, etc) and none of those mount commands work at all. If I add the -E parameter to the mount_smbfs command at all it won't work.

Any help would be greatly appreciated.

JSS
 

fumoretti

Newbie
Joined
Aug 30, 2018
Messages
2
So I don't have enough storage in my FreeNAS 11 server yet to transfer all my media content onto it yet. However, I'm wanting to run my Plex server on my Freenas server instead of on my Windows desktop. My plan to do this was to mount my Windows shares to Freenas and then add them to the Plex jail. This actually works great except for one thing. For some reason certain special characters won't show up properly in the smb mount in FreeNAS. It just shows a little question mark inside of a diamond character inside of Plex, and it just shows a question mark where the special character should be when using the ls command via ssh. I used this command to mount the Windows share in FreeNAS:

mount_smbfs -I <ip_address> //<host>/Movies /mnt/movies

Example of messed up filenames:
"Amélie" looks like this in on FreeNAS: Am?lie

I've tried to change the encoding using many variations of the -E parameter for mount_smbfs (-E utf-8:cp852 or cp866 or 852, etc) and none of those mount commands work at all. If I add the -E parameter to the mount_smbfs command at all it won't work.

Any help would be greatly appreciated.

JSS

hi @jsmith65 , i'm on the road to migrate our EMC² VNX5300 Unified NAS to FreeNAS 11.1 U5 and found exactly same problem. Based on your first post here and option -E of mount_smbfs i found the solution.

You need to specify on -E option the local_character_set:server_character_set. For me -E utf8:utf8 works very well!! My complete mount_smbfs commands is:

mount_smbfs -o ro -U domain_admin_user@mydomain.com.br -I mynas.mydomain.com.br -E utf8:utf8 //mynas/myshare /mnt/mynas_myshare_ro

here an example:

[root@nas01 ~]# ls -l /mnt/mynas_myshare_ro/folder1/folder2/Confi*
-rwxr-xr-x 1 root wheel 221184 Dec 13 2005 /mnt/mynas_myshare_ro/folder1/folder2/Configuração Concorrência Otimista.doc
[root@nas01 ~]#

Now i can migrate with much better performance my data to freeNAS.

good Luck!

Best Regards,

Franklin
 
Last edited:

jsmith65

Neophyte
Joined
Jun 8, 2018
Messages
5
Franklin, I just tried this and it does not work. When I add the -E parameter and enter the command it goes through without error, but upon listing the mount directory, it's blank so the mount did not work. If I remove the -E parameter entirely it will mount the share, but with character encoding issues as explained above.
 

jsmith65

Neophyte
Joined
Jun 8, 2018
Messages
5
I've finally found a solution to this problem. This mount_smbfs command works:

mount_smbfs -E koi8-r:cp866 -U <username> -I <server hostname/ip> //WindowsServer/location /mnt/local_mount_folder
 
Status
Not open for further replies.
Top