Failed to Join Windows Domain

Joined
Mar 18, 2019
Messages
1
Thanks
0
#1
Hi All,

Got [MiddlewareError: Active Directory failed to reload.] when try to join an old FreeNAS (11.2-U2.1 ) server to my Windows Domain.
I don't have any issue join new FreeNAS to the same domain.


Mar 18 09:06:11 FNT40 ActiveDirectory: /usr/local/bin/python /usr/local/bin/midclt call notifier.stop cifs
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-hostname quietstart
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-kerberos quietstart default TEST01.COM
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-nsswitch quietstart
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-ldap quietstart
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-kinit quietstart
Mar 18 09:06:14 FNT40 ActiveDirectory: kerberos_start: /usr/bin/kinit --renewable --password-file=/tmp/tmp.osBAdISsO FN40@TEST01.COM
Mar 18 09:06:15 FNT40 ActiveDirectory: kerberos_start: Successful
Mar 18 09:06:15 FNT40 ActiveDirectory: /usr/sbin/service ix-kinit status
Mar 18 09:06:15 FNT40 ActiveDirectory: kerberos_status: klist -t
Mar 18 09:06:15 FNT40 ActiveDirectory: kerberos_status: Successful
Mar 18 09:06:15 FNT40 ActiveDirectory: /usr/local/bin/python /usr/local/bin/midclt call notifier.start cifs
Mar 18 09:06:19 FNT40 ActiveDirectory: /usr/sbin/service ix-activedirectory quietstart
Mar 18 09:06:20 FNT40 ActiveDirectory: activedirectory_start: checking if we are joined already
Mar 18 09:06:20 FNT40 ActiveDirectory: AD_testjoin_domain: net -k ads testjoin TEST01.COM -S 192.168.10.2 -p 389
Mar 18 09:06:21 FNT40 ActiveDirectory: AD_testjoin_domain: Failed
Mar 18 09:06:21 FNT40 ActiveDirectory: activedirectory_start: trying to join domain
Mar 18 09:06:21 FNT40 ActiveDirectory: AD_join_domain: net -k ads join TEST01.COM -S 192.168.10.2 -p 389
Mar 18 09:06:22 FNT40 ActiveDirectory: AD_join_domain: Failed
Mar 18 09:06:22 FNT40 uwsgi: [middleware.exceptions:36] [MiddlewareError: Active Directory failed to reload.]


Any suggestion will be appreciated.
 

anodos

Belly-button Lint Extraordinaire
iXsystems
Joined
Mar 6, 2014
Messages
5,176
Thanks
1,369
#3
Hi All,

Got [MiddlewareError: Active Directory failed to reload.] when try to join an old FreeNAS (11.2-U2.1 ) server to my Windows Domain.
I don't have any issue join new FreeNAS to the same domain.


Mar 18 09:06:11 FNT40 ActiveDirectory: /usr/local/bin/python /usr/local/bin/midclt call notifier.stop cifs
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-hostname quietstart
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-kerberos quietstart default TEST01.COM
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-nsswitch quietstart
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-ldap quietstart
Mar 18 09:06:13 FNT40 ActiveDirectory: /usr/sbin/service ix-kinit quietstart
Mar 18 09:06:14 FNT40 ActiveDirectory: kerberos_start: /usr/bin/kinit --renewable --password-file=/tmp/tmp.osBAdISsO FN40@TEST01.COM
Mar 18 09:06:15 FNT40 ActiveDirectory: kerberos_start: Successful
Mar 18 09:06:15 FNT40 ActiveDirectory: /usr/sbin/service ix-kinit status
Mar 18 09:06:15 FNT40 ActiveDirectory: kerberos_status: klist -t
Mar 18 09:06:15 FNT40 ActiveDirectory: kerberos_status: Successful
Mar 18 09:06:15 FNT40 ActiveDirectory: /usr/local/bin/python /usr/local/bin/midclt call notifier.start cifs
Mar 18 09:06:19 FNT40 ActiveDirectory: /usr/sbin/service ix-activedirectory quietstart
Mar 18 09:06:20 FNT40 ActiveDirectory: activedirectory_start: checking if we are joined already
Mar 18 09:06:20 FNT40 ActiveDirectory: AD_testjoin_domain: net -k ads testjoin TEST01.COM -S 192.168.10.2 -p 389
Mar 18 09:06:21 FNT40 ActiveDirectory: AD_testjoin_domain: Failed
Mar 18 09:06:21 FNT40 ActiveDirectory: activedirectory_start: trying to join domain
Mar 18 09:06:21 FNT40 ActiveDirectory: AD_join_domain: net -k ads join TEST01.COM -S 192.168.10.2 -p 389
Mar 18 09:06:22 FNT40 ActiveDirectory: AD_join_domain: Failed
Mar 18 09:06:22 FNT40 uwsgi: [middleware.exceptions:36] [MiddlewareError: Active Directory failed to reload.]


Any suggestion will be appreciated.
Try manually running /etc/directoryservice/ActiveDirectory/ctl start
 
Top