Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

DDNS hostname in FTP Masquerade address

Joined
Aug 3, 2016
Messages
11
Thanks
0
#1
Hello,

I'm running FreeNAS 11.1 U4. I'm trying to enter a DDNS hostname into the FTP service's Masquerade address field. When I attempt to do this, it does not allow me:

upload_2018-3-25_15-33-23.png


However, in the 11.1 U4 documentation, it clearly states that I can use a hostname for this:

upload_2018-3-25_15-35-7.png


Is this a bug, was the documentation not updated, or am I doing something wrong?

Thanks,
Craig
 

m0nkey_

FreeNAS Expert
Joined
Oct 27, 2015
Messages
2,775
Thanks
989
#2
Joined
Apr 5, 2018
Messages
4
Thanks
0
#4
Is this something that someone is working on? I think 9.x had support for dns masq but since I updated to the newest build nether FTP or nextcloud are usable. Nextcloud is so outdated that the mobile client's won't work with it and since I can't use DNS name in the masquerade address FTP is unusable for me also :(
 
Joined
Aug 3, 2016
Messages
11
Thanks
0
#5
Is this something that someone is working on? I think 9.x had support for dns masq but since I updated to the newest build nether FTP or nextcloud are usable. Nextcloud is so outdated that the mobile client's won't work with it and since I can't use DNS name in the masquerade address FTP is unusable for me also :(
Yes, infernocs, I submitted a bug report and they're looking at it.
 
Joined
Apr 5, 2018
Messages
4
Thanks
0
#6
Anyone know where the IP address / dns name is stored? A config file maybe so I could put it in there. I can't figure out from the bugfix page weather or not it has been fixed.
 
Joined
Feb 6, 2015
Messages
30
Thanks
1
#10
Same problem... Any updates?
 
Joined
May 23, 2013
Messages
17
Thanks
0
#11
the "fix" for the bug was merged into the master branch in April 2018, I can't remember when i started watching this thread because I was having the same issue around that time. Maybe it's only fixed in some nightly release right now? I'm not sure when it would've made it to a specific release.

Worse comes to worst you can just run a chron job finding the IP address of your dynamic dns host, and use sed to put it into the proftpd config file and reload the config... or something like that. Lots of ways around it, it's just annoying that the easy method was botched for long enough.

https://redmine.ixsystems.com/issues/30687 was the bug. I just searched for ftp in the subject
 
Joined
Jun 22, 2011
Messages
15
Thanks
0
#12
BUMP! On v11.2. FTP won't start when using hostname instead of IP.

This is kind of important for an FTP for home users whos IP address typically changes over time. An option for the ftp server to retrieve its public IP would be best.
 
Top