Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED 11.2 U2 SMB shares worked fine, now gets access denied after updating to 11.2 U7

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE

Craigk19

Junior Member
Joined
Apr 16, 2019
Messages
19
I have been running 11.2 U2 with only 2 SMB shares since I set up my NAS box with no issues. My wife and I had Christmas pictures done so I got on to make a new share for Picture to make sure we don't ever lose them. As I logged into my GUI I remember a few days reading something about Freenas 11.3 so in the GUI have it check for updates and It has updates. I let them run and after the server reboots, I notice it's 11.2 U7. No big deal, I make my new dataset give it the same permissions and everything as my Plex Media dataset and smb share. On my Windows 10 machines, I can see the new share but get you don't have permissions when opening. That's weird double-check all settings, they all match my Plex media dataset and smb share. That's when I noticed I now get the same error when trying to open my Plex Media share as well as. I made no changes to my previously working shares. All I did was an update from 11.2 U2 to 11.2 U7. I checked the getfacl /mnt/Asgard/Plex Media on all levels and all return Owner: root and Group: Wheel with allowed across the board. I've made various changes and have not had any luck all have resulted in can see folders just can't access them. I even made a new user from scratch deleted then recreated the Pictures dataset to see if from "scratch" would work with no luck. Any help or direction would be greatly appreciated as my backups and plex server are all now dead in the water.
 

Craigk19

Junior Member
Joined
Apr 16, 2019
Messages
19
After playing with this most of the night and finding lots of posts close to but not the same as mine what fixed the issue was under Users on the Auxilary Group which was blank changed it to Wheel and now all Shares are working correctly again!
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
6,565
This is indicative of a lack of other e(x)ecute permissions on the root-level dataset of your data pool (for example, /mnt/tank). Membership of "wheel" should not be required for access to shares.
 

Craigk19

Junior Member
Joined
Apr 16, 2019
Messages
19
This is indicative of a lack of other e(x)ecute permissions on the root-level dataset of your data pool (for example, /mnt/tank). Membership of "wheel" should not be required for access to shares.
That's exactly what I thought too. Permissions on mnt/Asgard for me was set to root and wheel which confuses me. To me that seems right still. What doesn't make sense to me is I have mnt/Asgard/Backups and mnt/Asgard/Plex Media. The media is set up for everyone to have access and backups set up for just my user macrium only my macrium nightly and wheel and my other uses can still access the folder. So might have to give myself a crash course in permissions to avoid future issues like this.
 
Top