Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

PlexMediaServer Plugin Update Issues

FJep

Newbie
Joined
Mar 7, 2019
Messages
17
Hi,

today I had and solved some problems when installing Plex via Plugin-GUI in FreeNAS 11.2-RELEASE . I am writing this to help others with similar issues.
Yes I know there are other ways to keep Plex uptodate but when I updated to 11.2 Plex-Plugin was uptodate and I thought I would give the Plugin a try.

I was waiting for an update of PlexMediaServer plugin. Today I saw it in Plugins/Available update raised to version 1.15.2.793_1 (was still 1.14.x). When I looked at Plugins/Installed I found no option to update the plugin and under version was displayed N/A. I resolved the missing version by renaming my plugin from plex to plexmediaserver via SSH.
iocage rename plex plexmediaserver
That renamed /mnt/VOL/iocage/jails/plex to /mnt/VOL/iocage/jails/plexmediaserver but there was a plex.json left as is. So I renamed it it also changed its content to refer to plexmediaserver instead of plex. I am unsure what this file is used for. So feel free to enlighten me.
cd /mnt/VOL/iocage/jails/plexmediaserver
mv plex.json plexmediaserver.json
vi plexmediaserver.json

After that the correct version info was displayed :) but still no possibility to update from GUI, so I again used SSH.
iocage update plexmediaserver
iocage start plexmediaserver

Now Plex was raised to version 1.15.2.793 :) but the plugin already again seems to be outdated and shows an available update for version 1.15.3.876 :rolleyes:.

After logging in to Plex I had a new issue. With all options under Settings/Settings I got the message "Server settings are unavailable." (in german "Servereinstellungen sind nicht verfügbar."
The cause was a wrong entry in /mnt/VolZ1/iocage/jails/plexmediaserver/root/usr/local/etc/rc.d/plexmediaserver.
After changing
export LD_LIBRARY_PATH="${SCRIPTPATH}"
to
export LD_LIBRARY_PATH="${SCRIPTPATH}/lib"
all was Ok.

Bye Frank
 

Yorick

FreeNAS Guru
Joined
Nov 4, 2018
Messages
319
Hey, thanks for finding and fixing the issue with "Server settings are unavailable"! For what it's worth, plugin version 1.15.3.858 has that fixed and won't cause an issue during update.
 

FJep

Newbie
Joined
Mar 7, 2019
Messages
17
Hi Thorsten,

perhaps you can also tell me how and where the plugins are managed. I did not find the GIT in jira.ixsystems.com.

Unfortunatly plexmediaserver plugin is not updated yet only the plexpass version. I have a plexpass but am using the other plugin.
What is the difference between these versions?

Bye Frank
 

Yorick

FreeNAS Guru
Joined
Nov 4, 2018
Messages
319
Unfortunatly plexmediaserver plugin is not updated yet only the plexpass version. I have a plexpass but am using the other plugin.
What is the difference between these versions?
Plex Pass subscribers (https://www.plex.tv/plex-pass/ ) get early access to new versions. As I understand it, in FreeBSD/FreeNAS, this is on the "honor system". You can absolutely use the Plex Pass version of plexmediaserver without having a Plex Pass. Whether you can still look at yourself in the mirror at that point is another question. Since you have a Plexpass, you may as well use that version - you will need to copy your settings across though.
 

FJep

Newbie
Joined
Mar 7, 2019
Messages
17
I again have problems updating plexmediaserver.
I am on FreeNAS-11.2-U4.1 and using
using plexmediaserver plugin 1.16.2.1297 in IOCAGE 11.2-RELEASE-p4.
When doing update to 1.18.1.1973_1 it looks like this:
Code:
iocage update plexmediaserver
Snapshot: VolZ1/iocage/jails/plexmediaserver@ioc_update_11.2-RELEASE-p4 created.
Snapshotting plexmediaserver...
Updating plugin INDEX...

Host: 11.2-RELEASE is not greater than target: 11.3
This is unsupported.

Hope somebody can help.
 

Yorick

FreeNAS Guru
Joined
Nov 4, 2018
Messages
319
I just tried this on 11.2-U6 with plexmediaserver-plexpass and it got me to 1.17.0.1709. No warning about 11.3; also no attempt to go to the latest release built on 11.3.

FreeNAS 11.3 is going into beta MoreSoonerish(tm), and that will move it to FreeBSD 11.3, which then resolves the worry about FreeBSD 11.2 being EOL and all plugins being built on 11.3 by their maintainers.
 
Last edited:

FJep

Newbie
Joined
Mar 7, 2019
Messages
17
Under available plugins in FreeNAS Webgui is plexmediaserver 1.18.1.1973_1.
When I updated to 1.16.2.1297 som time ago also on FreeNAS-11.2-U4.1 all went well.
 

Yorick

FreeNAS Guru
Joined
Nov 4, 2018
Messages
319
> Under available plugins in FreeNAS Webgui is plexmediaserver 1.18.1.1973_1.

Yes that's my point. The error message you are getting indicates that the target for that version is 11.3-RELEASE. Which makes a lot of sense, given that FreeBSD 11.2 is EOL as of today.

Only one thing to do: Chill until FreeNAS 11.3 is at a stage where you're comfortable installing it.

This will continue to happen. FreeNAS 12.0 isn't even out yet, and FreeBSD 12.1 is about to be released within weeks. That means that come end of March/April 2020, thereabouts, FreeBSD 12.0 will go EOL. Will FreeNAS jump to 12.1 in time? Who knows.

If you gotta have the latest Plex right away, FreeNAS is not the best platform for that.
 

FJep

Newbie
Joined
Mar 7, 2019
Messages
17
But what is a plugin for when its not possible to install it anywhere?
Are there still plexmediaserver plugins which are working with 11.2 and how do I get them?
 

Yorick

FreeNAS Guru
Joined
Nov 4, 2018
Messages
319
> 11.2-U7 drops in a few weeks, and we'll be relaxing the restriction so you can deploy / upgrade 11.3 jails on it.

As per @Kris Moore

I've upgraded to 11.3-BETA1, and that, also, pulls in the latest plex plugin without issue.
 

ThreeDee

FreeNAS Experienced
Joined
Jun 13, 2013
Messages
255
I've upgraded to 11.3-BETA1, and that, also, pulls in the latest plex plugin without issue.
same here and I can also verify that I too have the latest plex
 
Top