Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

How to upload geli.key for pool

Joined
Sep 7, 2019
Messages
2
Thanks
0
#1
Hello

I've just setup my first FreeNAS, version 11.2.
I want to use an enrcypted raidz which contains 3 disks.

Setup was easy and everything is working.

I want to ensure that I'm able to recover data of the encrytped pool when the boot device fails.
Therefore I created a backup of configuration, geli.key and geli_recovery.key.
After that I did a fresh installation on a USB stick and uploaded the old configuration.

Then I tried to decrypt the pool.
In the unlock dialogue I always tried to enter the passphrase and upload geli.key
I took a while to read it correct. I don't have to enter a passphrase but upload geli_recover.key.
With that key I was able to decrypt the pool.
After a reboot everything was gone.
I thought that when I upload geli_recover.key everything should be fine.
Next try was to use geli_recover.key and change the passphrase afterwards.
The change passphrase dialouge has thrown an error that it's not able to modify /data/geli/xxx-xx-xx-xx-xx.key.
I copied backup geli.key to this location did a reboot and now everything is fine.

So my simple question in the end is:
Is there an easy way to upload a geli.key using the webinterface?

Thank you very much.
 
Top