Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Error when showing Available Plugins

Joined
Dec 22, 2018
Messages
2
I get a "popup" error message with this content:

<urlopen error [Errno 8] hostname nor servname provided, or not known>

Error: concurrent.futures.process._RemoteTraceback:
"""
Traceback (most recent call last):
File "/usr/local/lib/python3.6/urllib/request.py", line 1318, in do_open
encode_chunked=req.has_header('Transfer-encoding'))
File "/usr/local/lib/python3.6/http/client.py", line 1239, in request
self._send_request(method, url, body, headers, encode_chunked)
File "/usr/local/lib/python3.6/http/client.py", line 1285, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File "/usr/local/lib/python3.6/http/client.py", line 1234, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File "/usr/local/lib/python3.6/http/client.py", line 1026, in _send_output
self.send(msg)
File "/usr/local/lib/python3.6/http/client.py", line 964, in send
self.connect()
File "/usr/local/lib/python3.6/http/client.py", line 1392, in connect
super().connect()
File "/usr/local/lib/python3.6/http/client.py", line 936, in connect
(self.host,self.port), self.timeout, self.source_address)
File "/usr/local/lib/python3.6/socket.py", line 704, in create_connection
for res in getaddrinfo(host, port, 0, SOCK_STREAM):
File "/usr/local/lib/python3.6/socket.py", line 745, in getaddrinfo
for res in _socket.getaddrinfo(host, port, family, type, proto, flags):
socket.gaierror: [Errno 8] hostname nor servname provided, or not known
 
Last edited:
Joined
Dec 22, 2018
Messages
2
I figured this out. Once you set a static IP address, you also need to set a gateway and name servers. I didn't set the static IP with the gui, so there was no indication that more information was needed.

When displaying available plugins, FreeNAS should probably check for the gateway and name servers, and indicate that they need to be set if they aren't.
 

pschatz100

FreeNAS Guru
Joined
Mar 30, 2014
Messages
835
Glad you got it working. This is basic networking - not really a FreeNAS problem. If you had set this up through the FreeNAS GUI, it would have prompted you for all the necessary settings. When doing things manually, you have to understand what is going on. A good way to learn what's going on "under the hood."
 
Joined
Dec 29, 2019
Messages
2
i meet same problem in FreeNAS 11.2 U7, and i solved it by adding a hostname in /etc/hosts.
you can also enter "network->global configuration", edit "host name database" inputbox , add a hostname record. for example:
192.168.0.2 your_host_name
network configuration.jpg
 
Top