Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Download link not working

sretalla

FreeNAS Expert
Joined
Jan 1, 2016
Messages
1,969
I needed to allow pop-ups for the download to work... most modern browsers will block them by default, so I don't really understand why anyone would be using that method anymore...
 

sretalla

FreeNAS Expert
Joined
Jan 1, 2016
Messages
1,969
I also use a script blocker and needed to open an inordinate number of domains... I ended up using Opera (where I don't block scripts) and then allowed the pop-ups for the ix domain.
 

Wolfeman0101

FreeNAS Experienced
Joined
Jun 14, 2012
Messages
385
I also use a script blocker and needed to open an inordinate number of domains... I ended up using Opera (where I don't block scripts) and then allowed the pop-ups for the ix domain.
OK yeah I used Edge and it worked. This is a bit ridiculous.
 

Logikgear

FreeNAS Aware
Joined
Feb 22, 2016
Messages
43
I tried several times to no avail. I had to disable PFBlocker in PFsense then it would download.
 

JoshDW19

Community Moderator
Administrator
Moderator
iXsystems
Joined
May 16, 2016
Messages
457
Windows 2012 Server + Chrome (latest of both)
Can you double check your internet options to make sure allow JavaScript is enabled? I was under the impression JavaScript was disabled by default on server versions.
 

hescominsoon

FreeNAS Experienced
Joined
Jul 27, 2016
Messages
167
Still not working. Windows 10 pro with firefox the latest version. i disabled ublock origin completely..no popup notification either. Had to use edge(it doesn't care much about security) to get the download to appear.
 

Tigersharke

BOfH in User's clothing
Administrator
Moderator
Joined
May 18, 2016
Messages
215
I just verified that this is the case, that the download fails to appear, though I presently have a few plugins active in my Firefox on FreeBSD. One detail that has been missed is that the redirect URL is actually https://www.ixsystems.com/truecommand/getting-started/?submissionGuid=f11b6110-bbda-4262-b6e5-b2512e892d10 although the submissionGuid=
f11b6110-bbda-4262-b6e5-b2512e892d10
part is different for each attempt. I had to go into about:config to find whether javascript was enabled, it is. The download fails for me regardless.

PS.
One slightly humorous tidbit on the form: the country dropdown is a "drop up" due to it being at the bottom of the page, which means the preferential location of United States and Canada, are at the top of it and a fair distance from the cursor when clicked.
 
Last edited:
Top