Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Changed Jail IP, Then System Bricked at Startup

Joined
Jan 15, 2020
Messages
1
Hello, everyone, and thanks in advance for reading and for your expertise!

I have an existing FreeNAS system with an ASRock motherboard. I built the system a little over a year ago, and it has been working largely without issue since then. I use a USB drive to boot FreeNAS. I also have a Nextcloud jail on the device.

Recently, I upgraded my router and while I still had access to FreeNAS, my static IP on the Nextcloud jail stopped working, as it was outside the range of my new subnet. Last night, I logged onto the FreeNAS management console via freenas.local, logged in, and tried to adjust the jail's IP. To do this, I stopped the Nextcloud jail, updated the settings to add the appropriate settings, saved the new settings, then attempted to start the jail.

At this point, a number of things happened:
- The FreeNAS console locked up.
- My SONOS system - attached to the same network - stopped audio playback and ceased to function for about five minutes.
- My internet connection appeared to lock up for a few moments on all devices.

The best that I could guess was that my newly-introduced IP for the Nextcloud jail had caused an IP conflict, but when I ran a scan of the subnet, the IP I had selected appeared unused. It's also possible that the non-FreeNAS issues listed above were coincidental and not involved (though the timing is really suspicious). However, while the two non-FreeNAS issues resolved themselves in ten minutes or less, the FreeNAS system still seemed to be malfunctioning: attempting to open a new UI connection in a browser to freenas.local failed with the message that indicated that it was unable to connect to the web interface. A web search turned up that this often happened with an IP address change, and the prescribed fix was to access the box locally to fix the IP issue. However, when I connected a keyboard and a monitor, I didn't find the familiar options menu, but what looked like an interrupted startup. I did a hard restart of the box, and observed the following:

- A message that read "Waiting for BMC Initializing" with a countdown timer that slowly counted down to 30 (about a 3-5 minute wait);
- Once the timer cleared the system appeared to start;
- The box began to bootup normally but the startup hangs at exactly the same place each time (screenshot attached).

Back to the web search. I understand what BMC is but am not sure why it's failing, though because it has to do with networking, I'm wondering if it's related. Additionally, the place where the startup fails references "KCS mode found at iu 0xca2 on acpi" - which doesn't sound like an error - with or without a keyboard attached, and hangs there indefinitely (my most recent restart at about 11pm last night was still stuck there at 5pm tonight). The keyboard is fully responsive until after the FreeNAS/FreeBSD bootloader, then it becomes unresponsive (for example, Ctrl+Alt+Del does not restart the machine); I do note that the keyboard appears to be recognized by the startup script prior to where the script hangs.

I'm at a loss - both about the problem, and about how to diagnose it. The timing is exactly coincidental with the IP address change, and because BMC has to do with network-driven management, that's a clue these issues might be related, but I can't see what I would have done to cause an issue, and I also don't understand why/how changing the Jail's IP would have impacted the overall FreeNAS IP address.

I'm happy to provide any details that you might find helpful, and have attached a photo of the only part of the startup output visible when the startup script appears to lock up (one version with no keyboard attached; the other version *with* keyboard attached).
With Keyboard:
freenasstartup_withkeyboard.jpg


No Keyboard:
freenasstartup_nokeyboard.jpg


Hardware details are below:

ASrock Motherboard
16GB of DDR3-1600 RAM with ECC
Intel Core i3-4160 (3.60GHz) processor
UEFI - Version E3C224D2I P3.30

Aptio Setup Utility Version 2.17.1246


I very much appreciate your wisdom - I'm at a loss.
 
Top