Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Problem with Couchpotato renamer don't work

Xenosis

Newbie
Joined
Jan 6, 2020
Messages
1
Hello

I'm trying to setup Couchpotato on my new Freenas PC, but have some problems with moving and renaming files using CP's renamer feature.

If a place a movie in the folder that CP is looking for new movies(/mnt/.temp/Movies/) i get this error in the log:

CP-error-log.png


The mounted dataset have "xenosis" and group "shared" as permissions..

The folder I've told CP to move completed movies to: /mnt/Movies/

cp-renamer.png


I have created the group "shared" inside the jail and added the group to the user default user: couchpotato..
Inside couchpotato GUI I have no problems selecting the folders.. So I assume the GUI permissions are okay..

I have chown xenosis:shared all the folders and tried a few chmod permissions like 755 and 777 on the folders to:

Code:
root@couchpotato:/mnt # la -l
total 11
drwxr-xr-x+  5 1000  shared   5 Jan  4 02:25 ./
drwxr-xr-x  18 root  wheel   22 Jan  6 10:50 ../
drwxr-xr-x+  4 1000  shared   4 Jan  4 22:05 .temp/
drwxrwxrwx+  3 1000  shared   3 Jan  4 04:46 Movies/
drwxrwxrwx+  2 1000  shared   2 Jan  4 02:25 TV-Shows/

#### inside .temp folder ####

root@couchpotato:/mnt/.temp # la -l
total 2
drwxr-xr-x+ 4 1000  shared  4 Jan  4 22:05 ./
drwxr-xr-x+ 5 1000  shared  5 Jan  4 02:25 ../
drwxr-xr-x+ 3 1000  shared  3 Jan  6 13:17 Movies/
drwxr-xr-x+ 2 1000  shared  2 Jan  4 02:25 TV-Shows/


Does another user run the renamer function or why don't this work?

If I run ps aux | grep couchpoato inside the jail I get this:
Code:
root        87405  0.0  0.0  6732  2548 18  S+J  13:02   0:00.00 grep couchpoato

Sorry i'm bad at linux... But is this telling me that the user root is running couchpotato service?

And if I run: id couchpotato:
Code:
uid=950(couchpotato) gid=954(couchpotato) groups=954(couchpotato),1000(shared)


Don't know if this has anything to do with my problems.. But the movies placed in /mnt/.temp/Movies are transferred from a remote machine using Rsync and syncmd with these options:
RSYNC_OPTIONS="-avztu --chmod=Du=rwx,Dgo=rx,Fu=rw,Fgo=r --groupmap=xenosis:shared --out-format='[%t]--%n'"

If any additional info is need, please tell me and I will try to provide..

Can anyone tell me why this is not working?
 
Top