Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

NIC not negotiate giga speed

andrema2

Newbie
Joined
Aug 3, 2011
Messages
32
It was everything fine with 8.0.3 P1. My NIC was running at giga speed with no problem.

After I upgrade it to 8.0.4 release, my nic only works at 100TX, as you can see below.

ifconfig
re0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
ether 00:14:d1:15:52:a6
inet 192.168.1.114 netmask 0xffffff00 broadcast 192.168.1.255
media: Ethernet autoselect (100baseTX <full-duplex>)
status: active

If I try to force the speed via SSH I get this error
ifconfig: SIOCSIFMEDIA (media): Operation not permitted

How can I force it to use giga speed ?
 

peterh

FreeNAS Experienced
Joined
Oct 19, 2011
Messages
315
Change cable, change endpoint ( device at other end ) and finally NIC.
 
Top