Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

11.3 RC1 - No Messages from Syslog-NG

Joined
Aug 4, 2013
Messages
6
Greetings,
I'm trying out 11.3 RC1 and I've noticed that I'm not getting any forwarded logs like I used to in 11.2
I have a remote syslog destination specified in System > General.
With the level set to Debug I do get the forwarded messages from syslog-ng itself (below) but I don't get any actual messages from FreeBSD or the services running on it like I used to in 11.2.
Code:
<46>Jan  1 21:40:04 nas1 syslog-ng[13052]: Log statistics; processed='destination(messages)=3', processed='src.internal(src#3)=182', stamp='src.internal(src#3)=1577932204', processed='destination(authlog)=0', processed='destination(xferlog)=0', processed='destination(allusers)=0', processed='destination(maillog)=0', processed='destination(lpd-errs)=0', processed='destination(system)=0', processed='destination(cron)=0', processed='destination(debuglog)=0', processed='global(internal_queue_length)=0', processed='destination(consolelog)=0', processed='destination(ppp)=0', processed='destination(mdnsresponder)=0', queued='global(scratch_buffers_bytes)=0', processed='destination(security)=0', processed='destination(loghost)=182', processed='global(sdata_updates)=0', processed='global(msg_clones)=0', processed='center(received)=182', processed='destination(daemon)=0', dropped='dst.udp(loghost#0,udp,10.1.10.20:5514)=0', processed='dst.udp(loghost#0,udp,10.1.10.20:5514)=182', queued='dst.udp(loghost#0,udp,10.1.10.20:5514)=0', written='dst.udp(loghost#0,udp,10.1.10.20:5514)=182', processed='global(payload_reallocs)=358', queued='global(scratch_buffers_count)=0', processed='destination(nginx_error)=0', processed='center(queued)=185', processed='source(src)=182', processed='destination(nginx_access)=0', processed='destination(console)=0'
 
Joined
Aug 4, 2013
Messages
6
An update to my own post.
I noticed if I changed the syslog traffic to be on the standard port (514) I do get the messages. When the receiver was set to listen on 5514 and the FreeNAS setting was IP.AD.DR.ESS:5514 then only the messages from Syslog-NG itself showed up. Now that I have reconfigured the receiver to listen on 514 and the FreeNAS setting is IP.AD.DR.ESS the messages come through as expected.
 
Top