Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

zfs recv causing core dump

scurrier

FreeNAS Experienced
Joined
Jan 2, 2014
Messages
269
Thanks
11
#1
I am trying to backup a Proxmox hypervisor running on ZFS to a FreeNAS system using this command on the Proxmox system:
Code:
zfs snap -r rpool@pre_proxmox_upgrade_20190808
zfs send -Rv rpool@pre_proxmox_upgrade_20190808 | ssh root@10.0.200.11 zfs recv -x acltype -o aclmode=restricted backupone/proxmox/rpool


At the time of this command, FreeNAS has the dataset backupone/proxmox but no rpool underneath it.

Everything runs fine for a minute or two and data is flowing. I can see it advancing through the datasets that were beneath rpool. Then, it stops and I see this on the Proxmox system:
Code:
internal error: Invalid argument
Abort (core dumped)


On the FreeNAS side, I see this in /var/log/messages:
Aug 8 19:52:21 thumper kernel: pid 38825 (zfs), uid 0: exited on signal 6 (core dumped)

Any ideas how to resolve this?

I am running FreeNAS-11.2-U5.
 
Last edited:

dlavigne

Storage Engineering
Administrator
Moderator
iXsystems
Joined
May 24, 2011
Messages
11,331
Thanks
974
#2
Were you able to resolve this? If not, it might be worth reporting at bugs.ixsystems.com (post the link to the issue here if you do).
 

scurrier

FreeNAS Experienced
Joined
Jan 2, 2014
Messages
269
Thanks
11
#3
Didn't resolve it, just worked around. I am not sure what the expectation was for interoperability. I'm happy to create a bug if I can learn what relevant info to collect about it.
 

dlavigne

Storage Engineering
Administrator
Moderator
iXsystems
Joined
May 24, 2011
Messages
11,331
Thanks
974
#4
For the report to be useful we would need a debug created right after reproducing the issue.
 

scurrier

FreeNAS Experienced
Joined
Jan 2, 2014
Messages
269
Thanks
11
#5
Ok, I see in the docs how to get debug info. Is there much risk of sensitive info being in there?
 

dlavigne

Storage Engineering
Administrator
Moderator
iXsystems
Joined
May 24, 2011
Messages
11,331
Thanks
974
#6
The debug attachment itself is private to you and the developer.
 

scurrier

FreeNAS Experienced
Joined
Jan 2, 2014
Messages
269
Thanks
11
#7
@dlavigne Did Jira accounts get reset or something? My password didn't work and it won't send me a password reset, despite me being sure I entered the right username.
 
Top