Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

You can’t access this shared folder because your organization’s security policies block unauthenticated guest access.

Normdoggy

Newbie
Joined
Oct 17, 2019
Messages
1
I have did a search on this on the blog and cannot find anything on it. I've googled it and there are a lot of answers but none have worked. This just started right after I updated with the Windows 2020 update. My other two computers have no problem accessing the server. My group policy is correct and I've checked the Registry and it is also go to go. I am quickly running out of ideas.
 

Samuel Tai

Never underestimate your own stupidity
Moderator
Joined
Apr 24, 2020
Messages
1,259
This is because of a GPO on your workstation. Look in gpedit.msc, under Local Computer Policy->Administrative Templates->Network->Lanman Workstation, for the Enable insecure guest logons policy. If this is explicitly Disabled, then you'll get the message above.
 

murzik

Newbie
Joined
Jun 25, 2017
Messages
3
This is because of a GPO on your workstation. Look in gpedit.msc, under Local Computer Policy->Administrative Templates->Network->Lanman Workstation, for the Enable insecure guest logons policy. If this is explicitly Disabled, then you'll get the message above.
that does not work after windows 10 - 2004 update. You can try changing directly in registry, but that did not work form me either.
 

Samuel Tai

Never underestimate your own stupidity
Moderator
Joined
Apr 24, 2020
Messages
1,259

sretalla

Dedicated Sage
Joined
Jan 1, 2016
Messages
2,469
You could also just use a named user and turn off unauthenticated guest access on the share.
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
6,331
You could also just use a named user and turn off unauthenticated guest access on the share.
At the end of the day this is probably the correct answer. Microsoft is probably moving to deprecate this method of accessing SMB shares, and with good reason. MacOS also will prevent access to a guest share unless the user has explicitly selected that they want a guest session. Overall, the benefit of this "feature" is quickly disappearing.
 

entity279

Neophyte
Joined
Jan 16, 2017
Messages
9
I've rolled back away from 2004. Easier. It's shouldn't be up to microsoft to change the way I use my home network
 

cooldeepak

Newbie
Joined
Jun 29, 2020
Messages
1
Well figured it out. gpedit wasn't updating the reg key is seems.

Here is what I changed:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters] "AllowInsecureGuestAuth"=dword:1
 
Top