Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Working system died and can't load kernel

Joined
Aug 8, 2014
Messages
7
Ok... It's been a while since I've been here. I built my box to last and I'm confused about what changed or happened to break it. First off the OS is on a USB stick. 8GB in size. This box has been running for over 5 years without hiccups. I upgraded to 9.10 in July and it's been smooth sailing since then. The box died last week. I stuck a monitor on it and it says the following Screenshots, -1 -2 then -3 in the boot orders.

I really don't know what else to put here. I'm kind of at a loss. The 3rd screenshot shows the available commands. As far as I know, the drives are healthy as I did checks before the upgrades back in July. It's possible the USB died, sure. But it shows under the drive list without fail.

Any help would be wonderful as I've been spinning my wheels for the last bit here.
 

Attachments

styno

FreeNAS Experienced
Joined
Apr 11, 2016
Messages
436
It looks like your USB boot stick died. If you are building a box to last a (mirrored) SSD would be a good replacement option.
 
Joined
Aug 8, 2014
Messages
7
It looks like your USB boot stick died. If you are building a box to last a (mirrored) SSD would be a good replacement option.
I know this was months ago.. Just getting to this.

So how do I load a OS onto another usb drive and get my data back? Any tips/tricks or articles to throw at me?
 

styno

FreeNAS Experienced
Joined
Apr 11, 2016
Messages
436
Exactly the same way as you installed the first time, but import your backed-up config when the installation is done. (ps. it's all in the docs)
Just make sure that you disconnect your data disks while doing so and only reconnect them when your new install is running smoothly.
 
Top