Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Workaround for odd drill-down behaviour

Basil Hendroff

Neophyte Sage
Joined
Jan 4, 2014
Messages
1,044
I have TC sitting behind a Caddy reverse proxy and have trusted certificates for my FreeNAS servers. In TC, if I drill down to a server by clicking on the Go to Web Interface icon ...

screenshot.298.png


... I'd be presented with an empty window. I can get past this, by then clicking on View NAS in a New Tab in the top RHS of the window, however, apart from getting bothersome after a while, it results in an insecure server connection.

screenshot.299.png


I decided to investigate further last night. I realised, quite by accident, that the problematic field is the one shown below in the system configuration screen.

screenshot.300.png


I can avoid the previous empty web interface window and the insecure connection if I put the FQDN instead of the IP or hostname of the FreeNAS server in this field. Hope this helps anyone else experiencing a similar issue.

The TC documentation is scant on information for this System Configuration UI. I've yet to figure out what System Tokens is all about. Any takers?
 
Last edited:

Basil Hendroff

Neophyte Sage
Joined
Jan 4, 2014
Messages
1,044
OK. Now it's getting weird. It turns out that in order to avoid the empty web interface window and ensure secure communication between TC and a FreeNAS server, not only must I use the FQDN of the FreeNAS server in the system configuration screen as in the previous post, I also need to ignore SSL errors in the Administration panel.

screenshot.303.png
 

Attachments

Top