Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

vmx_init: VMX operation disabled by BIOS

Joined
Jun 11, 2019
Messages
2
Thanks
0
#1
I can not make bhyve VM working on my freenas system
my system is not runing inside ESXI and BIOS has opened VT support
but the dmesg shown disabled infomation as below
Code:
root@freenas[~]# grep vmx /var/run/dmesg.boot
vmx_init: VMX operation disabled by BIOS

Code:
root@freenas[~]# grep VT-x /var/run/dmesg.boot
  VT-x: (disabled in BIOS) PAT,HLT,MTF,PAUSE,EPT,UG,VPID,VID,PostIntr
 

sretalla

FreeNAS Expert
Joined
Jan 1, 2016
Messages
1,261
Thanks
321
#2
If (like me) you are running inside ESXi with your disk controller in PCI passthrough, you can't enable VTX-D, so it's jails only for you (and me... on that box).
 
Joined
Jun 11, 2019
Messages
2
Thanks
0
#3
If (like me) you are running inside ESXi with your disk controller in PCI passthrough, you can't enable VTX-D, so it's jails only for you (and me... on that box).
But My Machine installed Freenas System directly,not running inside ESXI
 

sretalla

FreeNAS Expert
Joined
Jan 1, 2016
Messages
1,261
Thanks
321
#4
But My Machine installed Freenas System directly,not running inside ESXI
OK, somehow missed the word "not" in your original post... apologies.

You need to look at your BIOS a bit harder and also check into your CPU support for virtualization if you think the BIOS is set to allow it already (usually should disable the option if no CPU support).

Maybe this will help in some way? https://www.instructables.com/id/Enable-Disable-Intel-VT-x/
 
Top