Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED VMs using FreeNAS 11 GUI - error connecting via VNC at linux setup

Status
Not open for further replies.

donsev

Member
Joined
Jan 15, 2017
Messages
77
I'm trying to create a VM in 11.0RC (stable): created a VM, added all devices, and am now trying to connect to it to begin the install process. Unfortunately my VNC hangs (specifically: "RFB protocol error: invalid message type 254") if I try to install either Ubuntu server 16.04, desktop 16.04/17.04, Solus, or budgie. It does work just fine when installing Windows 10 64bit, I get to the installation and everything.

So I guess my question is, is there a hidden setting somewhere I need to set when installing a linux distro? Is ubuntu installed without VNC? If so, how do I connect to the installation process? Using ssh and 'iohyve list' I don't see any VMs listed, beyond the ones I created manually using iohyve.
 

Stux

Wizened Sage
Joined
Jun 2, 2016
Messages
4,163
I'm trying to create a VM in 11.0RC (stable): created a VM, added all devices, and am now trying to connect to it to begin the install process. Unfortunately my VNC hangs (specifically: "RFB protocol error: invalid message type 254") if I try to install either Ubuntu server 16.04, desktop 16.04/17.04, Solus, or budgie. It does work just fine when installing Windows 10 64bit, I get to the installation and everything.

So I guess my question is, is there a hidden setting somewhere I need to set when installing a linux distro? Is ubuntu installed without VNC? If so, how do I connect to the installation process? Using ssh and 'iohyve list' I don't see any VMs listed, beyond the ones I created manually using iohyve.
Try setting your quality level to high in the VNC client session configuration instead of Auto.

https://bugs.freenas.org/issues/23977

If that is your issue, you should tack onto that bug report...

Otherwise, they did mention something about resolutions...
 

donsev

Member
Joined
Jan 15, 2017
Messages
77
Try setting your quality level to high in the VNC client session configuration instead of Auto.

https://bugs.freenas.org/issues/23977

If that is your issue, you should tack onto that bug report...

Otherwise, they did mention something about resolutions...
Goodness, that was easy. I can access it just fine now. I'll add to that report and recommend this be put somewhere on the gui. Thank you!
Try setting your quality level to high in the VNC client session configuration instead of Auto.

https://bugs.freenas.org/issues/23977

If that is your issue, you should tack onto that bug report...

Otherwise, they did mention something about resolutions...

Sent from my XT1575 using Tapatalk
 

pdxnerd

Newbie
Joined
Jun 14, 2017
Messages
1
Thanks, this worked for me as well. Luckily this was the top result on Google for me.
 

diskdiddler

Dedicated Sage
Joined
Jul 9, 2014
Messages
2,108
Guys is this broken again? I've got garbled graphics with VNC Viewer 6.17 on port 5901 and I've set to medium, low and high - no joy?
 

Ziggy

Member
Joined
Oct 7, 2015
Messages
108
Me too with the garbled graphics. And the annoying thing is I know I managed to fix it but cant remember how. Doh!
 

diskdiddler

Dedicated Sage
Joined
Jul 9, 2014
Messages
2,108
Anyone?
 

Ziggy

Member
Joined
Oct 7, 2015
Messages
108
I did reduce the resolution to less than HD and this resulted in text being slightly more visible (try different lower resolutions if the first doesn’t work) and I was then able to choose the right options to boot into Linux (two steps). Once this was done and before Linux was fully booted to the login screen graphics became fully visible.
 

diskdiddler

Dedicated Sage
Joined
Jul 9, 2014
Messages
2,108
You're right, I dropped the resolution in the properties of the VNC 'device' in the VM properties and low and behold I'm finally working.
 
Status
Not open for further replies.
Top