Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

UniFi iocage jail disappeared from GUI after reboot [FNAS11.1U1]

Status
Not open for further replies.

sinbrkatetete

Neophyte
Joined
Nov 15, 2016
Messages
4
Hello!

I'm not really sure what info to give to make helping me as easy and as fun for the eventual help-giver as possible, so I'll list the generals.
- FreeNAS-11.1-U1
- Intel Xeon CPU E3-1225 v5
- 8024 MB RAM
- 4×4TB HDDs
Use:
- file server for my home office - 1 zpool RAIDZ2, 6 datasets (company1,company2,family,backup,iocage,jails)
- syncthing plugin
- unifi iocage jail

Tonight we experienced a blackout. The FreeNAS did what it was supposed to, shut down "gracefully" upon receiving "the news" from the UPS. After a couple of minutes the power came back, I started the machine, the FreeNAS booted, but... The UNIFI jail disappeared from the GUI. No mention of it anywhere. After browsing the iocage dataset, I confirmed it still existed by listing the jails with iocage list -q and successfully started it with iocage start UNIFI. This didn't bring the jail back in GUI (didn't expect it to, just mentioning), but the UniFi controller is fully functional ATM.

Also, I can't remember for the life of me if there were any network interfaces listed under Network -> Interfaces but there aren't any listed now. At the same time, under Reporting -> Network there are three interfaces listed: bridge0, em0, epair0a. Is this normal?

Thanks in advance to any and all who spend a brain cycle on my problem.

EDIT: I tried the new GUI and there it is... The UNIFI jail is listed under jails. Only the UNIFI jail, the syncthing one is not there for a change.
 
Last edited:

danb35

Wizened Sage
Joined
Aug 16, 2011
Messages
11,328
I tried the new GUI and there it is... The UNIFI jail is listed under jails. Only the UNIFI jail, the syncthing one is not there for a change.
Yes, that's to be expected. iocage jails don't appear in the old GUI; warden jails don't appear in the new GUI.
 

sinbrkatetete

Neophyte
Joined
Nov 15, 2016
Messages
4
Yes, that's to be expected. iocage jails don't appear in the old GUI; warden jails don't appear in the new GUI.
Gosh darn it, I'm sorry for taking up space here. I've set up the server some time last year and haven't had the time to familiarize myself with it; haven't touched it except to back it up and update it. Thanks for the answer.

BTW, the network interfaces stuff is also normal behavior?
 
Status
Not open for further replies.
Top