Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.
Supermicro X10 and X11 motherboard FAQ

Supermicro X10/X11 motherboard FAQ

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
16,139
Thanks
3,867
#1
Please note:

This guide has been moved to the Resources section of the forum and is available there. Future updates will be posted there.

This thread now contains the archive of the last version of the guide before it was migrated and also functions as the discussion for that Resource.

The original version (well, with all the updates until 2016-05-14...) is available below:


Despite being the default choice for most of us, Supermicro X10 motherboards have certain quirks. These range from poorly documented solutions to relatively common issues to deliberate choices by Supermicro that may raise questions.

This post is meant to answer some of the more common questions, including detailed instructions on how to fix recurring issues, where appropriate. It is also meant to guide prospective Supermicro X10 owners, as a proactive source of information.

Before we move on to the FAQ proper, a few warnings:

Some procedures mentioned here may carry the risk of bricking your motherboard, which may be irreversible. These will be marked by the following warning:
Do not attempt unless you are having the problem described above.

While I have personally executed all "risky" procedures I recommend and believe that the risk is minimal, be aware that there is a non-zero risk of something bad happening.
To reduce this risk, please ensure stable power (preferably with a UPS) is maintained to the system during the entire procedure.
Again, the risk is there, but it's small. If your problem does not match, you might want to ask in the forums before proceeding anyways.

I may group several questions that lead to the same issue. These will be marked by a lack of text immediately following the title.


I need help choosing the right Supermicro X10/X11 board
What are the differences between models?


There are several different models that I feel are appropriate for a server.
I have written a guide on this subject, for X10 motherboards, which explains the differences between these models.
Similarly, a guide to LGA1151 X11 motherboards is also available.

What's new in the X11 boards?

Besides the usual incremental improvements in the CPU, the Skylake platform brings the following to the table:
  • Support for up to 64GB of DDR4, in 16GB UDIMMs
  • Up to 8 SATA 6Gb/s ports (up from 6)
  • Extra PCI-e connectivity
  • PCH only supports XHCI for USB. This means that FreeNAS 9.3.1 and older versions DO NOT support booting from USB. They will probably not work with USB keyboards (or other USB HIDs) either - or anything USB, for that matter. FreeNAS 9.10 supports XHCI properly and all USB ports work normally.

What RAM should I buy?
What's with Kingston RAM and why shouldn't I use it?
[X10] I have 16GB Kingston RAM, can't I upgrade?


I have written a guide on this subject, which can be found here.
It includes a thorough discussion on RAM for the Supermicro X10 series.

Not much information is available for X11 boards yet and Supermicro's QVLs are still rather sparse.


[X10] What CPUs are compatible?

In principle, all LGA1150 CPUs should work with LGA1150 Supermicro X10 motherboards. Naturally, only models that support ECC are under serious consideration - this means Pentiums, i3s and Xeon E3s.

Please note that Haswell Refresh processors (released in 2014, compared to Haswell’s 2013 launch date) need the 2.0 BIOS or later to work.
Similarly, Broadwell processors (Xeon E3 v4) require the 3.0 or later BIOS.

I will be investigating details regarding CPU support and will update this entry accordingly. If you have any relevant information or tips, feel free to PM me.


[X11] What CPUs are compatible?

Due to changes Intel made to the Skylake platform, I am hesitant to say that non-ECC processors should work. In practice, there is no good reason to use a CPU that does not support ECC anyway, so this should not be a problem for most people.

Supermicro guarantees compatibility with Skylake Celerons, Pentiums, i3s and Xeon E3s.


How do I flash the BIOS?

Unlike most desktop motherboards, the simple BIOS flashing method requires a product key from Supermicro. This means we'll need to load an OS and do it from there.

Supermicro provides the latest BIOS version and a flashing tool. These are available for various OSes.

The safest option is probably to use some kind of DOS. I used a FreeDOS live USB drive - particularly the Odin (a more basic than standard) distro. The "regular" distro provided on the same image did not work, failing with an error.


All the sensors read N/A

First of all, make sure you're not in the BIOS setup menu. IPMI monitoring of sensors isn't available there.

If that is not the case, the procedures listed under "The CPU/PCH temperatures read N/A" may help.


The CPU/PCH temperatures read N/A

While the exact cause is unknown, the BMC may enter a faulty state, requiring a reset.

The following options were recommended to me by Supermicro:

  • Start by power cycling the IPMI. This can be done from the web interface.
  • If that doesn't work, reset it to factory defaults via the web interface and power cycle it (it will not work until it is properly power cycled).
Do not attempt unless you are having the problem described above.
  • If all else fails, reflashing the Management Engine firmware should do the trick. However, this is only possible in a certain ME recovery mode dictated by jumpers. Please contact Supermicro for details. Your specific motherboard model's manual may explain the procedure.

    For the X10SLM+-F (may not apply to other models!), the JPME1 and JPME2 must bridge pins 2 and 3.


    In this mode, flashing the BIOS will also flash the ME firmware. After flashing, turn everything off and unplug everything. Clear CMOS and reset the jumpers to their original positions.

Once the problem is solved, reconfigure everything via the IPMI web interface.


My server's fans keep spinning up and down
Fan thresholds are set to unrealistic values, how do I change them?
Setting IPMI sensor thresholds


Supermicro X10 motherboards have their fans monitored by the BMC, which automatically attempts to recover stalling (of the motor, not in the aerodynamic sense) fans by spinning them up to maximum (PWM set to 100% speed). This behavior is determined by the sensor thresholds.

Supermicro X10 motherboard fan profiles are controlled via IPMI. Unfortunately, only very basic functions are exposed via its web interface and Supermicro's own IPMI utility is superbly well hidden on Supermicro's website and uses Java. The pragmatists among us would complain about Java, use the application, and move on - however, for some reason (*cough* Java *cough*) Supermicro application and its nice GUI do not always work properly. Thus, third-party universal IPMI tools are needed.

I have written two guides dedicated to this issue, with step-by-step instructions:
Part 1, which uses ipmitool, can be used directly on FreeNAS.
Part 2, which uses ipmiutil, is meant for use on a remote client machine.


I would like to learn more about how the fans are managed

GrumpyBear explains many details in his Thermal and Accoustical Design Validation thread.


My long IPMI password doesn’t seem to work
What’s the limit on IPMI password length?


Empirical evidence suggests that the IPMI solution on the Supermicro X10 series only allows passwords up to 19 characters in length. This seems to be undocumented, however.


[X10SL7-F] - The LSI SAS2308 flashing tool won't work under DOS

Some UEFI motherboards have trouble flashing LSI SAS 2008/2308 controllers outside of the EFI shell.

The easiest solution is to boot into the UEFI shell and use the sas2flash.efi tool.

Specific instructions should be similar to the DOS version of the utility, but be sure to consult the official documentation.


Update 2014-09-06 - Minor clarifications and corrected typos.
Update 2015-01-30 - Expanded FAQ, minor formatting changes, minor updates
Update 2015-04-02 - Added Thermal and Accoustical Design Validation
Update 2015-07-05 - Added Broadwell information
Update 2015-08-26 - Corrected link to "So, you've decided to buy a Supermicro X10 board" thread. Previously linked to comment further down, instead of OP.
Update 2015-11-29 - Added information on X11 boards, renamed accordingly.
Update 2015-12-27 - Added what's new in X11 section, including USB XHCI warning.
Update 2016-04-01 - Updated XHCI warning, in light of FreeNAS 9.10 existing.
Update 2016-04-27 - Added general sensors N/A heading
Update 2016-05-14 - Corrected N/A sensors under BIOS sentence, special thanks to @BigDave
 
Last edited:
Joined
Oct 11, 2016
Messages
88
Thanks
4
#2
So I just got my hands on the Beta IPMI Version for my X11SSH-F (R 1.34) from SuperMicro! It has a few updates and some things polished up a bit.. BUT MOST OF ALL.. is has HTML5 Support now! This may be old new to some, but I thought I would still post this b/c I have been looking around for anything "X11SSH-F" and haven't seen this yet. Below is a link to my Dropbox with the file:

https://www.dropbox.com/s/941zez0ju598c3s/SMT_X11_134.bin?dl=0
upload_2017-3-26_6-49-35.png


View attachment 17127

upload_2017-3-26_6-52-18.png


I wasn't able to install this over the Web GUI so I had to use the IPMIView Software:
upload_2017-3-26_6-49-6.png



Now to the WHY I got my hands on this...
A few reasons the SM (SuperMicro) helped me out:
1) I wasn't able to get my KVM (remote counsel) to work on my Mac. I even found the IPMIView for Linux workaround to work on the Mac, but was still unable to get the KVM to work. So SM helped me out!
upload_2017-3-26_6-54-14.png

2) I'm having issues (and still am even after the firmware update) with the IPMI "Dropping Out?" If its being accessed all the time (like Sensor Readings on Auto Refresh or bouncing back and forth through the tabs/menus), it stays happy and alive/wake.

If it hasn't been accessed for a few hours or so. When I say "Dropping Out", I mean that I just can't "Find" the IPMI device on the network. BUT the actual network still shows it's alive and active (all lights on, router shows ONLINE, etc), I just can't access it via IPMIView App on my iPhone 6, IPMI Web Interface, or IPMIView Software.

AT TIMES, it's almost like I have to "Jump Start" it. I can get access to it if I try a bunch of ways (Chrome, Safari, IPMIView iOS app, IPMPView Software, etc) and then it picks up (or more like WAKES UP). Once "Woke" I can get access all the features except at times just NOT the KVM? VERY STRANGE!

Needless to say, if ANYONE can lend a hand on some things I should try to get this working, I would be EVER so grateful!

What I am using:
- Comcast Xfinity Router/Modem
- Netgear GS108T Switch
- X11SSH-F Motherboard (.. ya, we know that one...)
- R2.0 BIOS on Motherboard
- R1.34 IPMI
- iMac with the latest Chrome and Safari
- iPhone 6 with the latest updates
- Running Stable Corral (doesn't really matter here, just pointing it out)

What I have tried:
- Resting EVERYTHING
- Cold Rest of the IPMI from the IPMIView Software
- Different Ethernet Cables
- Different Ports
- Plugged directly into the Router, not through the switch
- Made the IPMI connection "Dedicated" instead of the default "Failover"
- Made the IPMI IP "Static"
- Working with SuperMicro

Thanks guys!
 
Joined
Oct 11, 2016
Messages
88
Thanks
4
#3
UPDATE:

So everything worked "Just OK" after that update EXCEPT I could not run the KVM interface on my iPhone 6 and i had to do some strange jump start procedure. Once I get it going though, all was well.... except the KVM. I emailed SM and they sent me another Firmware version to use. This time it was R 1.28.

EVERYTHING works WONDERFULLY now!
upload_2017-3-27_22-3-16.png


Here is the link if anyone would like to have it! I'm VERY pleased with how SM has helped me out and has be so responsive!!

https://www.dropbox.com/s/r9oap3mgsavyy20/SMT_X11_128.bin?dl=0
 

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
16,139
Thanks
3,867
#4

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
16,139
Thanks
3,867
#5

colmconn

FreeNAS Aware
Joined
Jul 28, 2015
Messages
94
Thanks
25
#6
I read this thread on reddit last night about the Ubiquiti UAS-XG being based on a SuperMicro motherboard and how the poster was having issues updating the BIOS using the IPMI "Supermicro Out of Band (OOB) Software License Key" method. They then go on to link to a sit where someone documented how the figured out how those OOB keys are generated. To method is documented here. This may be of interest to some of you Supermirco owners.
 

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
16,139
Thanks
3,867
#7
I have previously used that method on both my boards successfully. So have others.
 

VictorR

FreeNAS Experienced
Joined
Dec 9, 2015
Messages
143
Thanks
6
#8
Worked for me, too
 
Top