Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED (SOLVED)dataset shows ~500 GB but I can't see any files

Joined
Jul 10, 2019
Messages
2
Thanks
0
#1
Using FreeNAS-11.2-U2, first time using FreeNAS. I have a few datasets created, one of which shows that it is using 524G of storage, but if I go to the SMB share for this dataset or even SSH into the server and look at it in the /mnt/ directory, I can't find any of the files that should be using up this space. Can anyone help me out here? I had a lot of music/movies/photos that are only partially backed up on another drive.

In the SSH shell I can use zpool to see the ZFS pools:

Code:
zpool iostat
                 capacity     operations    bandwidth
pool          alloc   free   read  write   read  write
------------  -----  -----  -----  -----  -----  -----
Vault          524G  2.21T      0      8  6.01K   126K
freenas-boot   758M   148G      0      0  17.1K    660
------------  -----  -----  -----  -----  -----  -----


So now I list the datasets inside "Vault":

Code:
zfs list -r Vault
NAME                                                     USED  AVAIL  REFER  MOUNTPOINT
Vault                                                    524G  2.12T   160K  /mnt/Vault
Vault/.system                                            489M  2.12T   470M  legacy
Vault/.system/configs-02e83c25ec534b63a4d545000fc9a19d  6.37M  2.12T  6.37M  legacy
Vault/.system/cores                                     2.38M  2.12T  2.38M  legacy
Vault/.system/rrd-02e83c25ec534b63a4d545000fc9a19d      8.84M  2.12T  8.84M  legacy
Vault/.system/samba4                                     284K  2.12T   284K  legacy
Vault/.system/syslog-02e83c25ec534b63a4d545000fc9a19d   1020K  2.12T  1020K  legacy
Vault/.system/webui                                       88K  2.12T    88K  legacy
Vault/Cloud                                              524G  2.12T   524G  /mnt/Vault/Cloud
Vault/Cloud/MediaShare                                    88K  2.12T    88K  /mnt/Vault/Cloud/MediaShare
Vault/Cloud/Minecraft                                     88K  2.12T    88K  /mnt/Vault/Cloud/Minecraft
Vault/PalmerFiles                                       2.01M  2.12T  2.01M  /mnt/Vault/PalmerFiles


And I can see that "Cloud" is 524G!! So I navigate over to the Cloud directory in the file system and try du -sh * to show directory sizes, and not much seems to be in there. MediaShare should be over 500G as it holds all the photos/video/music/etc.

Code:
usr@freenas:~/Cloud % du -sh *
512B    MediaShare
1.1G    minecraft
1.0K    Minecraft
1.4G    PalmerFiles


Any ideas where the files might have gone??
 
Joined
Jul 9, 2019
Messages
8
Thanks
0
#2
Do you have snapshots? The data might be hidden there.
You did your "du" run in ~/Cloud is that really the same as /mnt/Vault/Cloud?
 
Joined
Jul 10, 2019
Messages
2
Thanks
0
#3
I actually found the solution in this thread last night. Someone had a similar problem where the drives showed that something was occupying space but they couldn't find see files.

Turns out I had a folder in Cloud called MediaShare, as well as a dataset in Cloud also called MediaShare. The MediaShare dataset was empty but was getting mounted over the folder MediaShare which contained all the files. All I had to do was zfs umount Vault/Cloud/MediaShare and suddenly I could see the all the files in the folder MediaShare.

And yes ~/Cloud is the same as /mnt/Vault/Cloud for this user, as the home directory is set to /mnt/Vault/.
 
Top