Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Setting up FreeNAS 9.2.0 with Transmission and Couchpotato as a DLNA-Server

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
Thanks for the great tutorial, I followed it and it worked. My server then refused to boot no idea why why but it is likely to have been some of the other stuff I've been trying. I then thought that it would be way easier if you could install all the plugins into one jail. Then u just have to share the one media folder and things get a lot easier. This is very possible...

Create a plugin jail, and add the raw_sockets=true, setting. Copy it from the transmission jail config. Then visit the jails help page on freenas , or click here

http://www.freenas.org/downloads/plugins/9/

Download all the pbis u want and then upload them by clicking the brown pbi button when viewing the jails. U essentially end up with the same thing, but they are all on the same jail! So only one media directory to mount.
Yes, that's entirely possible, and I hope, someone will do it and document it!

04-19 13:05:39 INFO [re.providers.info.omdbapi] Found: Pacific Rim (2013)
04-19 13:05:39 INFO [tato.core.plugins.renamer] Same quality release already exists for Pacific Rim, with quality 720p. Assuming repack.
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim.srt"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim cd2.orig.txt"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim cd1.orig.nfo"
04-19 13:05:39 INFO [tato.core.plugins.renamer] Removing "/media/movies/Pacific Rim (2013)/Pacific Rim.mkv"
[/CODE]

EDIT: is it my fault because I put the /media/movies folder in "Manage"? I think that might be it... D'OH!
That's it. See the part of the code I snipped. Happened also to me the first time.;)
just wondering if anyone knows how to fix this issue (see screen shot) my transmission shows a torrent I tried to download but the status is 710.7 kb of 1.63 GB (0.04%) and it’s stuck at that point. Above the torrent theres an error:

Error: Permission denied (/media/downloads/Captain America The Winter Soldier 2014 TS XviD MP3 MiLLENiUM/Sample.avi)


I followed these instructions (excellent job btw!!) and have successfully installed, mapped each plugin to their respective folders. I created a jail for Plex, and then installed the following plugins from the directory - CouchPotato, Sickbeard, and transmission. I then also installed and connected the Transmission remote GUI.

I created a dataset labeled “Media” and within this I created a movies, series, music, photos, torrents, downloads folder. Permissions were automattically set to 0755 and this dataset is assigned to nobody:no group (although I’d like to change this later).

The error above seems like an obvious permissions issue but I can’t seem to figure it out. I checked via ssh the folder in question “media/downloads” - they were 755. I changed them to 777 but it still returned the same error. Any ideas or suggestions on what I should do??

Thanks in advance!
Did you change Folder and File CHMOD in Couchpotato as shown below? Did you change the permissions to 777 recursively?
 

noobi3

Junior Member
Joined
May 2, 2014
Messages
24
I have a problem with sickbeard its postprocessing is not working

I know about putting the right directory where torrents are downloaded



2014-05-02 00:20:59 ERROR POSTPROCESSER :: Exception generated in thread POSTPROCESSER: error 2 : No such file or directory
2014-05-02 00:20:59 WARNING POSTPROCESSER :: Processing failed for /sickbeard/downloads/Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]/21 Anything Could Happen.mp4:
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10] 21 Anything Could Happen.mp4'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'/sickbeard/downloads/Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]/21 Anything Could Happen.mp4'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'21 Anything Could Happen.mp4'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name None
2014-05-02 00:20:59 INFO POSTPROCESSER :: Processing /sickbeard/downloads/Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]/21 Anything Could Happen.mp4 (None)
2014-05-02 00:20:59 WARNING POSTPROCESSER :: Processing failed for /sickbeard/downloads/Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]/20 Hanging On.mp4:
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10] 20 Hanging On.mp4'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'/sickbeard/downloads/Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]/20 Hanging On.mp4'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'20 Hanging On.mp4'
2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name None
2014-05-02 00:20:59 INFO POSTPROCESSER :: Processing /sickbeard/downloads/Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]/20 Hanging On.mp4 (None)
2014-05-02 00:20:59 WARNING POSTPROCESSER :: Processing failed for /sickbeard/downloads/Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10]/22 Paper Planes & Playground Games.mp4:

2014-05-02 00:20:59 INFO POSTPROCESSER :: Analyzing name u'Ellie Goulding - Halcyon [Deluxe Edition] [2012] (iTunes+Extra videos+Digital Booklet) [F10] 22 Paper Planes & Playground Games.mp4'
This a log of my sickbeard the problem is its only finding general folders not the TV Shows

When i Manual Post Process i get error 500



But when i create a folder in my downloads folder and add any TV show episode it process fine


These are my Jail Setup




Any help would be appreciated

 

Attachments

laspo

Neophyte
Joined
Apr 3, 2014
Messages
8
Hi zufallsheld,

Nice guide! I followed it to the letter but I'm still having some trouble. Maybe you could help me out?

1) I added a TV Show (Hannibal) to my list in Sick Beard and search for all the episodes of season 2. It only snatched one: S02E02. It didn't find any other episode and gave the error "Error loading EZRSS URL: http://re.zoink.it/...". Is this because of the limited support for torrent downloads? Or is it something else?

2) I continued with the one torrent it managed to snatch and looked it up via CIFS. The torrent was correctly placed in jails/sickbeard_1/media/torrentfiles. So I checked if he put it in the dataset. And yes he did! The torrent is also in mediaheaven/torrentfiles. So now Transmission should pull that file into his jail (jails/transmission_1/media/torrentfiles. But there is no torrent-file to be found there. I double checked the added storage of the jail (see pic), it seems about right. Is there maybe a refresh time for Transmission to pull in the torrent files to his jail? Or should I check the option "Mounted?" ?

3) I continued anyway by going to the web client of Transmission and upload the torrent manually. But at 0.50 % it says Error: Permission denied (/media/downloads/Hannibal.S02E02.720p.HDTV.X264-DIMENSION.mkv). I checked as root with SSH (PuTTy) the permissions of the folder media in its jail:

drwxr-xr-x 6 root wheel 6 May 3 13:23 media/

and

drwxr-xr-x 2 root wheel 2 May 3 13:22 downloads/
drwxr-xr-x 2 root wheel 2 May 3 13:23 movies/
drwxr-xr-x 2 root wheel 2 May 3 13:23 series/
drwxr-xr-x 2 root wheel 2 May 3 13:23 torrentfiles/

I also checked the permissions of the datasets and it was still assigned to nobody and nogroup with everything checked (including recursively).
Any ideas on this?

Best regards!
 

Attachments

diedrichg

Neophyte Sage
Joined
Dec 4, 2012
Messages
1,284
Why mess with transmission for nzb downloading? Why not just use SABnzbd for downloading and post processing?

As for not snatching an episode; keep in mind that your Usenet provider has a limited retention time and that file may not be available anymore.
 

laspo

Neophyte
Joined
Apr 3, 2014
Messages
8
Why mess with transmission for nzb downloading? Why not just use SABnzbd for downloading and post processing?

As for not snatching an episode; keep in mind that your Usenet provider has a limited retention time and that file may not be available anymore.
I'm not messing with Transmission for nzb downloading. I'm messing with it for torrent downloading. Anyhow, problems 2 and 3 are resolved by checking the "Mounted?" option.

As for nzb, what service do you use? And do you think it's worth the money. Because torrents are... well, free.
 

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
I have a problem with sickbeard its postprocessing is not working

I know about putting the right directory where torrents are downloaded





This a log of my sickbeard the problem is its only finding general folders not the TV Shows

When i Manual Post Process i get error 500



But when i create a folder in my downloads folder and add any TV show episode it process fine


These are my Jail Setup




Any help would be appreciated

Sorry, I cannot help you there. Maybe ask here: https://github.com/midgetspy/Sick-Beard
 

diedrichg

Neophyte Sage
Joined
Dec 4, 2012
Messages
1,284
As for nzb, what service do you use? And do you think it's worth the money. Because torrents are... well, free.
I'll p.m. you as this is not the place for this type of discussion.
 

LAYGO

Member
Joined
Dec 21, 2011
Messages
85
I love Transmission Remote GUI. Also, if you have an android phone, you can do it all from your phone too with TransDroid.

http://www.transdroid.org/

It does have a version that is permitted on Google Play, but it doesn't have the search feature available from the website. The website version is constantly being updated too. TransDroid can control many different type of bittorrent daemons too.

Transmission Remote GUI & TransDroid are my goto apps!
 

Mike Haskell

Junior Member
Joined
Jan 17, 2014
Messages
14
Once couchpotato moves and renames the movie, can the file be deleted from the media/downloads directory without losing the movie making room for more downloads?
Mike
 

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
Once couchpotato moves and renames the movie, can the file be deleted from the media/downloads directory without losing the movie making room for more downloads?
Mike
Yes, you can delete the files from the downloads-directory. The movie is copied to the "movies"-directory. However if you want to seed the movie, you should not delete it.
 

Pteronura

Newbie
Joined
Jul 11, 2014
Messages
1
First I want to say thank you for putting together this tutorial, I would never have been able to set this up myself. I do have a bit of a problem, however. Most everything seems to be working well (sickbeard doesn't, but that's because ezrss is down) except that I have to manually move files from the Transmission jail into my Plex jail in order to get them to show up on the web interface. It's my understanding that the directory structure should take care of all that for me.
 

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
First I want to say thank you for putting together this tutorial, I would never have been able to set this up myself. I do have a bit of a problem, however. Most everything seems to be working well (sickbeard doesn't, but that's because ezrss is down) except that I have to manually move files from the Transmission jail into my Plex jail in order to get them to show up on the web interface. It's my understanding that the directory structure should take care of all that for me.
You're missing one step. Transmission downloads the files to /media/downloads. From there, Sickbeard or Couchpotato take the files, then put them to /media/movies or /media/series. Only if the file are in theses folders, Plex can use them.
 

Fragsrus

Neophyte
Joined
Jul 23, 2014
Messages
8
So, when I am trying to add the storage to my jails I keep getting this error:
Error: [MiddlewareError: The path could not be mounted /mnt/media/downloads: Mount failed (64) -> mount: /mnt/media/jails/transmission_1/media/downloads: No such file or directory ]

I have the box checked for "Create Directory" and I also have permissions set to "noowner" and "nogroup" with read/write/execute set for owner/group/other for the entire volume. I have followed the steps exactly up until the sharing portion, as I am using CIFS. I created the shares for each dataset and have them each set to "Allow Guest Access".

I am not sure where the problem is that is stopping me from creating the directories within the jails; any help would be greatly appreciated.
 

Fragsrus

Neophyte
Joined
Jul 23, 2014
Messages
8
Well, after a some research, it appears this is a known bug with the latest version of FreeNAS and is expected to be addressed in the next release version. In the mean time, I used putty to SSH into the jail and manually create the subfolders for the jail storage.
 

zufallsheld

Member
Joined
Dec 27, 2013
Messages
54
Well, after a some research, it appears this is a known bug with the latest version of FreeNAS and is expected to be addressed in the next release version. In the mean time, I used putty to SSH into the jail and manually create the subfolders for the jail storage.
Glad you figured it out by yourself!
 

JJT211

Senior Member
Joined
Jul 4, 2014
Messages
317
Excellent guide! Thanks for the write up!

I'm having a problem accessing any of the Plugin WebGUI's in all of my jails. I've gone over everything and even completely reinstalled Freenas and followed guide to word for word but still cant access the GUI.

The Plugins appear to start up just fine but when I look in the server command line interface I get these errors. The first one is when I start up the transmission plugin, the second is my server sitting at idle.
 

Attachments

Last edited:

JJT211

Senior Member
Joined
Jul 4, 2014
Messages
317
Update: I was having a similar problem as Fragas. For some reason the new directories will not mount when you tick the 'create new directory' box. I initially disregarded it becuase the new directories were in fact created but they werent mounted which is necessary to access the plugin webgui.

Big Thanks to Fragas. I'm all sorted now.
 
Last edited:

SpiritFly

Member
Joined
Jul 11, 2014
Messages
25
Yup BIG THANKS to @Fragsrus (or is it Fragas lol) ! I happened to stumble upon his post right when I was doing that step and I knew exactly what to do.

I sure hope this will be soon resolved too!
 

SpiritFly

Member
Joined
Jul 11, 2014
Messages
25
just wondering if anyone knows how to fix this issue (see screen shot) my transmission shows a torrent I tried to download but the status is 710.7 kb of 1.63 GB (0.04%) and it’s stuck at that point. Above the torrent theres an error:

Error: Permission denied (/media/downloads/Captain America The Winter Soldier 2014 TS XviD MP3 MiLLENiUM/Sample.avi)

A little history on my setup and plugins:
Running freenas 9.2.0-Release-x64 (ab098f4)

Build FreeNAS-9.2.0-RELEASE-x64 (ab098f4)
Platform Intel(R) Pentium(R) CPU G3220 @ 3.00GHz
Memory 16323MB


I followed these instructions (excellent job btw!!) and have successfully installed, mapped each plugin to their respective folders. I created a jail for Plex, and then installed the following plugins from the directory - CouchPotato, Sickbeard, and transmission. I then also installed and connected the Transmission remote GUI.

I created a dataset labeled “Media” and within this I created a movies, series, music, photos, torrents, downloads folder. Permissions were automattically set to 0755 and this dataset is assigned to nobody:no group (although I’d like to change this later).

The error above seems like an obvious permissions issue but I can’t seem to figure it out. I checked via ssh the folder in question “media/downloads” - they were 755. I changed them to 777 but it still returned the same error. Any ideas or suggestions on what I should do??

Thanks in advance!
Excellent guide and congrats for making it so perfect!

I'm having the exact same trouble as @Nayeem. Not sure what this means. All permissions are set as suggested?

EDIT: For some odd reason, the problem went away after a while. Not sure what I did, but I don't recall changing anything important..
 
Last edited:

JJT211

Senior Member
Joined
Jul 4, 2014
Messages
317
OK, what I meant by manually creating the sub-directories was creating a folder through Win Explorer. It sort of worked by giving me the directory to mount and I was finally able to get to the WebGUI of all my plugins. But when I was in the WebGUI of Coachpotato, I was unable to select the downloads or movie subdirectory in the 'Download to this Directory' box. Im thinking creating the folder in Win Explorer didnt actually work but just tricked the plugin into letting me into the WebGUI.

So my question is, where do I find the commands to manually create the directories by SSH using putty?
 
Status
Not open for further replies.
Top