Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Problems with accessing Plex on local network

Joined
Jan 18, 2020
Messages
1
Hi Guys,

So I'm pretty new to FreeNAS and any server work. I recently decided to turn my old PC into a home server and run Plex on it. I have spent the past few days pulling my hair out because, whenever I try to access Plex from a laptop or my Shield it only connects using the external IP.

Having done a little research into my problem, the best I can tell is Plex is ignoring my VNET connection in the jail because it ignores any adaptor that starts with the letter "V". I tested this out by disabling VNET and DHCP then when I tried getting onto Plex from my Shield it worked fine, only problem was that Plex wasn't getting an internet connection and wouldn't download metadata etc...

Going by this thread:

It seems that I need to change the name of my VNET but I have no idea how to do this. I have tried editing the rn.conf file by accessing it through my windows share but I don't have the permissions to save any changes.

I'm using FreeNAS 11.3RC2 and the version of Plex in the jail is 11.3-RELEASE-p5 or Version 1.18.3.2129.

One weird thing to mention, though I'm unsure of how relevant it is, although I can't connect from my Shield Plex App I can access through the Plex Web app on a browser on my desktop PC and when I check Plex's dashboard whilst playing media it does say its a local connection with direct stream.

If there is any other info you need to help me then please let me know and thanks in advance for any help you guys can offer.
 

BlueScreenTT

Newbie
Joined
Mar 26, 2018
Messages
55
Question is plex on a different subner / iprange than your client ?
my server is on 192.168.110.11 and my client is on 192.168.100.101 that do not work until i edit the pref file and and the networks
 
Top