Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Probleme mit dem POOL

Joined
Jan 4, 2020
Messages
6
Moin moin Community,

ich habe vor ein paar Tagen die Hardware in ein neues Gehäuse einziehen lassen; Habe plötzlich Probleme mit dem Pool - er findet es nicht mehr. Der "Import an existing pool" funktioniert nicht. Nach der Auswahl vom Pool "HDD1" (Name vom Pool) kann er es nicht wieder erstellen.

Ich hoffe auf eure Hilfe :-/

LG & ein schönen Abend
 
Joined
Jan 4, 2020
Messages
6
Habe einfach mal das Gerät neugestartet und im Bios geschaut ob irgendwelche Einstellungen sich geändert haben - diese sind unverändert.

Als das NAS eben dann starten wollte, kam auf dem Display welches daran angeschlosen ist eine Fehlermeldung "KDB: enter: Panic […] Stopped at kdv_enter+0x3b […]"
 
Joined
Jan 4, 2020
Messages
6
Hier 1x meine Hardware

Mobo: Supermicro c9z390
CPU: 8500-T
RAM: 2x16GB 2400er nonECC/nonFB
HDD: IronWolf 8TB (2x)
 
Joined
Jan 4, 2020
Messages
6
Hab ein wenig gegooglet, in älteren Threads wurde empfohlen eine, oder mehrere HDDs raus zu nehmen.

Freenas startet mit der ada0 HDD; bin dann in die Shell gegangen und habe mit "zpool Status" & "zpool Import" folgende Infos.


Last login: Sat Jan 4 23:23:47 on pts/2
FreeBSD 11.2-STABLE (FreeNAS.amd64) #0 r325575+c9231c7d6bd(HEAD): Mon Nov 18 22:46:47 UTC 2019
FreeNAS (c) 2009-2019, The FreeNAS Development Team
All rights reserved.
FreeNAS is released under the modified BSD license.
For more information, documentation, help or support, go here:
Welcome to FreeNAS
Warning: settings changed through the CLI are not written to
the configuration database and will be reset on reboot.
root@cubebot[~]# zpool status
pool: freenas-boot
state: ONLINE
scan: scrub repaired 0 in 0 days 00:00:05 with 0 errors on Thu Jan 2 03:45:05 2020
config:
NAME STATE READ WRITE CKSUM
freenas-boot ONLINE 0 0 0
nvd0p2 ONLINE 0 0 0
errors: No known data errors
root@cubebot[~]# zpool import
pool: HDD1
id: 4659762881325210380
state: DEGRADED
status: One or more devices were being resilvered.
action: The pool can be imported despite missing or damaged devices. The
fault tolerance of the pool may be compromised if imported.
config:
HDD1 DEGRADED
mirror-0 DEGRADED
ada0p2 ONLINE
replacing-1 UNAVAIL insufficient replicas
3211802980765960678 UNAVAIL cannot open
4594119477161220000 UNAVAIL cannot open
root@cubebot[~]#
 
Joined
Jan 4, 2020
Messages
6
Hier ein kleines Update... habe die "ada1" (dank HS) im betrieb reingesteckt und nun sieht es so aus...

root@cubebot[~]# zpool import
pool: HDD1
id: 4659762881325210380
state: DEGRADED
status: One or more devices were being resilvered.
action: The pool can be imported despite missing or damaged devices. The
fault tolerance of the pool may be compromised if imported.
config:
HDD1 DEGRADED
mirror-0 DEGRADED
ada0p2 ONLINE
replacing-1 DEGRADED
3211802980765960678 UNAVAIL cannot open
gptid/0fe1ce6d-2e89-11ea-b30d-ac1f6b676aa0 ONLINE
root@cubebot[~]#
 
Top