Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Plex not able to stream video or download meta data

Joined
Aug 7, 2019
Messages
24
Thanks
0
#1
Hi this is my first time using FreeNAS and jails.

For some reason, I am not able to download any meta data on movies or tv shows and I am not able to stream any movies or tv shows from plex. I have tried reinstalling Plex and restarting the server... Any ideas as to what is wrong?

I've taken some screenshots of my Freenas setup:

My interface (Only use on for the moment)
Screenshot 2019-08-25 at 20.46.41.png


My global network
Screenshot 2019-08-25 at 20.47.03.png


My dataset (plexstorage)
Screenshot 2019-08-25 at 20.47.16.png

Screenshot 2019-08-25 at 20.47.38.png

Screenshot 2019-08-25 at 20.48.06.png


My jail mount point
Screenshot 2019-08-25 at 20.48.57.png
 
Joined
Aug 7, 2019
Messages
24
Thanks
0
#2
Update, I tried setting the jail to use DHCP and I can confirm that it now works. So somehow i f'ed up the static IP... Will update if I get it to work with static IP
 
Joined
Jul 10, 2016
Messages
280
Thanks
158
#3
What matters for plex is that the VNET option is turned on. Depending on the specific release of FreeNAS, that option may or may not show on the basic screen; go to the advanced options if needed. Also, the default value of VNET depends on the specific release.

Note that when you check DHCP, VNET is automatically activated, but when you uncheck DHCP you're on your own.

If you're on FreeNAS-11.2-U5, below is a screenshot of how it should look. Don't forget to enter the IP address of your router in IPV4 Default Route.


1566782659308.png



As an alternative, just use DHCP and logon to your router to set a DHCP reservation for the desired IP address.
 
Joined
Aug 7, 2019
Messages
24
Thanks
0
#4
What matters for plex is that the VNET option is turned on. Depending on the specific release of FreeNAS, that option may or may not show on the basic screen; go to the advanced options if needed. Also, the default value of VNET depends on the specific release.

Note that when you check DHCP, VNET is automatically activated, but when you uncheck DHCP you're on your own.

If you're on FreeNAS-11.2-U5, below is a screenshot of how it should look. Don't forget to enter the IP address of your router in IPV4 Default Route.


View attachment 32509


As an alternative, just use DHCP and logon to your router to set a DHCP reservation for the desired IP address.
Okay, I was not aware that VNET is required for Plex, since I read on some forum posts, that disabling VNET solved their issues. I will try and set a static IP again and keep VNET turned on.
 
Top