Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Mixing disks of different sizes in a VDEV is not allowed (but the drives are the same model and size...)

Joined
Feb 7, 2020
Messages
2
Testing with 11.3 on a Supermicro X10SBA (J1900) with 8GB of ram.

I have 4 x 250GB Seagate drives installed, 3 are the same model. I can get two of the drives to allow me to create a pool if I use the 'suggest layout' option but if I manually try to add the drives (again, 3 with the same model number and size) I get the error below.

All three drives are:

Rotation Rate: 7200
Model: ST3250310NS


1581133583231.png
 

Heracles

FreeNAS Guru
Joined
Feb 2, 2018
Messages
504
Hey Curtis,

This looks like a bug... Lets try to identify which drive is different according to this...

Can you please create a first vDev of 2 drives using drives ada1 and 2. Then you do it again with ada3 and 4. If successful, you destroy them and do it with ada1 and 3, then 2 and 4. Finally, you re-re-create them with 1 and 4 and 2 and 3.

Let see if that can spot more details about this strange behaviour. In all cases, drives of different sizes can be mixed and matched. Only thing is that the vdev will be sized according to the smalllest one.

Good luck doing your debug,
 
Joined
Feb 7, 2020
Messages
2
Thanks. I can only make a vdev using disk 1 and 4 or 2 and 3, but not any other combination.

1581175098098.png


Any other combination gives me the 'Mixing disks of different sizes in a VDEV is not allowed'.
 

Heracles

FreeNAS Guru
Joined
Feb 2, 2018
Messages
504
Hi again,

Ok... Strange... I do not have 11.3 here... Is the Legacy UI still available ? Can you try creating your pool with it ? Also, can you try all combination of 3 drives to see if a single one works or not ? (1-2-3 ; 1-2-4 ; 1-3-4 ; 2-3-4) ?

Another option would be trying using to create the vdev from CLI.
 

blueether

FreeNAS Experienced
Joined
Aug 6, 2018
Messages
243
file a bug report, this is going to be anoying for so many people
 
Joined
May 7, 2018
Messages
4
I just ran into this same issue with 6x WD Red 6TB drives. Found this other thread where someone was able to do it in 11.2-U7.
I made a new usb with that build. Now it's just a warning instead of a blocking error: Mixing disks of different sizes in a VDEV is not recommended.
So it sounds like the bug already exists pre-11.3, it's just that now it's an error in 11.3.
Was a bug ever filed for this?

And as for my pool, should I be worried that something isn't quite lining up correctly? Will there be some kind of perf impact down the line if this results in my pool being initialized wrong?
 

cobrakiller58

FreeNAS Experienced
Joined
Jan 18, 2017
Messages
358
11.2-U7 had the legacy UI so we could override the restriction there, iX in their attempt to protect users from themselves removed that ability with the death of the legacy UI in this ticket
If you have SSD's from different manufacturers good luck
 

Kris Moore

VP of Engineering
Administrator
Moderator
iXsystems
Joined
Nov 12, 2015
Messages
155
Fix is in progress. We're going to make it a bit less strict on the checking, but also provide an override as well, in case somebody really does want to make a mixed size vdev.
 
Top