Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Lost on changing working jail networking to use VLAN

Joined
Dec 10, 2018
Messages
18
Thanks
1
#1
Seems like with every topic I find that appears similar to my issue, I just get completely lost with figuring anything out. So please, forgive my lack of knowledge/experience on this front.

What I have was a working iocage jail in FreeNAS 11.2-U5 that was previously using the same network as the host, but I want to put this jail on a separate VLAN. To make things easy, I already have tagged VLANs configured and working with other things in my home so no need to really investigate anything to do with the networking hardware side of things.

My FreeNAS host has only one network cable, and it is on an untagged VLAN 1 on network 192.168.10.0/24. No LAGG or anything fancy. On the same wire is VLAN2 (tag=2) from my smart switch.

Under Network > VLANs, I created a new VLAN interface named "vlan2", parent interface is "igb0", tag is "2".

The router on this VLAN2 interface is 192.168.2.1, the network is a /30 subnet, therefore the only other host I want on here is the jail and I want it to use 192.168.2.2.

Seeing as how the networking in the jail was working fine out of the box, I stopped the jail to make edits to its network configuration from the webGUI:
IPv4 DHCP is disabled
VNET is enabled
BPF is disabled
IPv4 interface was changed from "vnet0" to "vlan2", address, netmask, and default router was modified accordingly.

When I started the jail and logged in, I found it no longer has a working network connection. This is what IFCONFIG shows:
Code:
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
    options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    inet 127.0.0.1 netmask 0xff000000
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    groups: lo


I also had a look at /etc/rc.conf
Code:
ifconfig_epair0b="DHCP"
hostname="testjail"

cron_flags="$cron_flags -J 15"

# Disable Sendmail by default
sendmail_enable="NONE"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"

# Run secure syslog
syslogd_flags="-c -ss"

# Enable IPv6
ipv6_activate_all_interfaces="YES"


In some threads I read how some folks created system tunables, or did stuff with their interfaces and bridges. Some were successful, others weren't.
I tried changing ifconfig_epair0b="DHCP" to
ifconfig_vlan2="inet 192.168.2.2 netmask 255.255.255.252"
defaultrouter="192.168.2.1"

and restarted the jail, but it's still not working and I don't understand enough to know why. Please help?
 
Joined
Dec 10, 2018
Messages
18
Thanks
1
#3
No, I was not.
 
Top