Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

LACP Freenas 8.0.4 r2 <-> Cisco 2960G

Joined
Jun 7, 2012
Messages
3
Hi,

I have a LACP connection between the Freenas 8.0.4 and my Cisco switch, currently with only 1 cable.
Acording to the cisco switch and Freenas the LACL channel is up, but my problem is when I try to send traffic over the LACP connection nothing happens. Trying to ping my gateway do now work, timeout.
Using another NIC on the freenas (not in LACP) to the same switch in the same vlan works.

Here the configuration and stats:

interface Port-channel2
description LACP to Freenas server 1
switchport access vlan 10
switchport mode access

interface GigabitEthernet0/4
description LACP port to Freenas server 1
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 2 mode active

CISCO#sh etherchannel 2 port
Ports in the group:
-------------------
Port: Gi0/4
------------

Port state = Up Mstr Assoc In-Bndl
Channel group = 2 Mode = Active Gcchange = -
Port-channel = Po2 GC = - Pseudo port-channel = Po2
Port index = 0 Load = 0x00 Protocol = LACP

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.
A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi0/4 SA bndl 32768 0x2 0x2 0x105 0x3D

Partner's information:

LACP port Admin Oper Port Port
Port Flags Priority Dev ID Age key Key Number State
Gi0/4 SA 32768 b499.baaa.bad7 11s 0x0 0x90 0x2 0x3D

Age of the port in the current state: 0d:01h:32m:37s

lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 9000
options=219b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MAGIC>
ether b4:99:ba:aa:ba:d7
inet 10.199.0.11 netmask 0xffffff00 broadcast 10.199.0.255
media: Ethernet autoselect
status: active
laggproto lacp
laggport: em1 flags=1c<ACTIVE,COLLECTING,DISTRIBUTING>

Any idea why no traffic parses the LACP channel??

Regards
Robert
 

louisk

FreeNAS Experienced
Joined
Aug 10, 2011
Messages
433
I expect it has to do with having multiple links, one of which is LACP and the other which is not. I've never tried this config, but it sounds a little odd. I would put all the interfaces for a given VLAN into a single LACP LAGG and test that. I have that setup on a 2960g (same config cisco side) and it works great.
 

andyl

Newbie
Joined
Apr 20, 2012
Messages
76
interface Port-channel2
description LACP to Freenas server 1
switchport access vlan 10
switchport mode access

interface GigabitEthernet0/4
description LACP port to Freenas server 1
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 2 mode active
A couple of stupid questions....
Is the host from which you're pinging also in VLAN10?
Does VLAN10 exist in the switch database? (I always forget to create them)
 
Joined
Jun 7, 2012
Messages
3
louisk was right. It was due to the fact I had both a LACP interface and a "normal" interface configured.
I deleted the normal interface and added it to the LACP interface, rebooted and it worked.

Thanks.

Robert
 
Top