Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Issue with ISCSI

mst

Newbie
Joined
Aug 17, 2014
Messages
65
Thanks
3
#1
Experts,

Last night we had a power issue and looks like I lost ISCSI storage from freenas. I think something might be with connection. Any thoughts. Please let me know what info I should post please. I use FreeNAS-11.1-U6 that is connected to Cisco 4900 and I use 10GB uplink ports.

Thank you
 

Attachments

Joined
Apr 8, 2012
Messages
98
Thanks
16
#2
A lot of times I lose the drive on the ESX side when I have power outage etc.

If the ISCSI service is running on freenas then you can try this on the ESX side to see if its ESX. This needs to be ran on the ESX box, I usually just start SSH, and esxi shell.

esxcfg-volume -l this will let you know if it sees it.

esxcfg-volume -M labelname will mount it.
 

mst

Newbie
Joined
Aug 17, 2014
Messages
65
Thanks
3
#3
I see

[VMware vCenter - Alarm alarm.NetworkConnectivityLostAlarm] Lost network connectivity on virtual switch "vSwitch3". Physical NIC vmnic6 is down. Affected portgroups:"ISCSI4", "ISCSI3"

[VMware vCenter - Alarm alarm.NetworkRedundancyLostAlarm] Lost uplink redundancy on virtual switch "vSwitch3". Physical NIC vmnic7 is down. Affected portgroups:"ISCSI4"

looks like from ESX both uplinks goes down - any idea? I know this is probably the cause. Faulty card? Cables?
 

mst

Newbie
Joined
Aug 17, 2014
Messages
65
Thanks
3
#4
From ESX I cannot ping FreeNas aggregate IP:

[root@vmhost6:~] ping 192.168.10.7 10GB CARD on ESX
PING 192.168.10.7 (192.168.10.7): 56 data bytes
64 bytes from 192.168.10.7: icmp_seq=0 ttl=64 time=0.027 ms
64 bytes from 192.168.10.7: icmp_seq=1 ttl=64 time=0.019 ms

--- 192.168.10.7 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max = 0.019/0.023/0.027 ms
[root@vmhost6:~] ping 192.168.10.6 10GB CARD on ESX
PING 192.168.10.6 (192.168.10.6): 56 data bytes

--- 192.168.10.6 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss
[root@vmhost6:~] ping 192.168.10.9 FREENAS LINK AGG
PING 192.168.10.9 (192.168.10.9): 56 data bytes

I think connection is an issue here - any thoughts?
 

mst

Newbie
Joined
Aug 17, 2014
Messages
65
Thanks
3
#5
I only wonder how am I restore LUNS on Freenas when I fix the issue with the connection
 
Joined
Apr 8, 2012
Messages
98
Thanks
16
#6
Are you using a switch or are these directly connected?
 
Joined
Aug 17, 2014
Messages
65
Thanks
3
#8
ESX shows ports up:

vmnic6 0000:05:00.0 ixgbe Up Up 10000 Full a0:36:9f:14:64:a8 1500 Intel(R) Ethernet Controller X540-AT2
vmnic7 0000:05:00.1 ixgbe Up Up 10000 Full a0:36:9f:14:64:aa 1500 Intel(R) Ethernet Controller X540-AT2
 
Joined
Aug 17, 2014
Messages
65
Thanks
3
#9
Freenas shows:

lagg0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=e407bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
ether a0:36:9f:14:66:cc
inet 192.168.10.9 netmask 0xffffff00 broadcast 192.168.10.255
nd6 options=9<PERFORMNUD,IFDISABLED>
media: Ethernet autoselect
status: no carrier
groups: lagg
laggproto loadbalance lagghash l2,l3,l4
laggport: ix0 flags=0<>
laggport: ix1 flags=0<>
 
Joined
Aug 17, 2014
Messages
65
Thanks
3
#10
I connect FreeNAS with ESX directly using both 10Gb ports. I am attaching EX PATHS since I don't think this is right. I should them both have active 10GB when using ISCSI - correct?
 

Attachments

Joined
Apr 8, 2012
Messages
98
Thanks
16
#11
You have to set your paths to in ESX to either round-robin or alua to get it to use both paths. It really only helps if they are super busy. You can also use a script and powercli to do this on all devices if you have a bunch. I used to use something like this at my last job it only sets it on drives over 100GB though as written.

Code:
Get-VMHost | Get-ScsiLun -LunType disk | Where {$_.MultipathPolicy -notlike "Fixed" -and $_.MultipathPolicy -notlike "Roundrobin"  }  | Where {$_.CapacityGB -ge 100} | Set-Scsilun -MultiPathPolicy RoundRobin
 
Top