Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Issue with DHCP when creating jails (FreeNAS in XCP-NG)

Joined
Jan 14, 2020
Messages
2
Hi there! I've been using FreeNAS (virtualized) on XCP-NG for around six months now. I use FreeNAS in a production environment in which I host media/file storage for my household.

I was looking into Nextcloud recently and thought it would be a great service to try out. But, I've ran into an issue. Due to me not being able to find a viable way to use a network share to host Nextcloud's main data folder within a VM, I would like to be able to use a jail instead.

That being said, I've been at this for a few days... and whenever I throw up a test FreeNAS VM, I am unable to create a jail which uses DHCP without it resulting in kernel panic.

HW Spec:
Dell R720xd
2x Intel E5-2650 v2
128GB Ram
Intel I350 Quad Port NIC
H310 mini mono (IT Mode)
12x 2TB Seagate SAS Drives

I am able to create a jail, and install the Nextcloud plugin directly without DHCP enabled. Of course the issue being, I don't have access to the internet from within the jail. I have tried creating a second VIF on a separate Ethernet port, as well as tried enabling promiscuous mode.

Questions I haven't been able to find an answer to:

Do I need a separate NIC?

Is this an issue with virtualizing FreeNAS with XCP-NG?

Do I need to be using a bonded network? (See below)

What I will be trying out next is creating a bonded network, and attempting to use DHCP after enabling promiscuous mode. I will update this post after I get home tomorrow and have tried that.

In the meantime, has anybody here used FreeNAS within XCP-NG, and could perhaps point me in the right direction?
 

artlessknave

FreeNAS Experienced
Joined
Oct 29, 2016
Messages
352
does xcp-ng require promiscuous mode? xcp-ng on esxi, for example, requires enabling promiscuous mode on the esxi side for any network to work in the nested VM's.
 
Joined
Jan 14, 2020
Messages
2
I don't believe it does. I was just reading through things that worked with FreeNAS under esxi, and was hoping some parallels would exist there. As an update, I tried using a bonded network. (Creating it via Xen Orchestra, and assigning it to the FreeNAS VM.) I also enabled promiscuous mode, to no avail. After doing some more research however, I read that there apparently have been some issues using nested virtualization with FreeBSD based OS's and XCP/XCP-NG. I haven't found a workable solution at this time. I'll keep scouring the internet at this point. And update this post if I come across anything.
 

amp88

Newbie
Joined
May 23, 2019
Messages
51
I believe I'm experiencing the same issue as you (running XCP-ng 8.0 on a Dell R730). I posted a thread about it, and will let you know if I come across a solution. I'm going to watch your thread too, in the hopes you might succeed.
 
Top