Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Intel RS2WC080 Raid Controller (Model LSI SAS9240-8i)

Status
Not open for further replies.

Azukay

Neophyte
Joined
Aug 22, 2012
Messages
10
After many hours of scouring the internet and testing, I have finally manged to get this controller working on a new UEFI mainboard (Asus P8H77-M Pro) and functional under Windows Server 2012 x64 RC (same driver as Win8 x64 RTM).
I have also successfully flashed this chip to a LSI 9211-8i IT mode (HBA).
I am successfully running FreeNAS 8.3 as a VM in VMware Workstation 9 with this RAID card after flashing.

***Disclaimer***
***All of this is done at your own risk. I recommend having the equipment you are working with plugged into a UPS, if you lose power during a firmware update you might brick the controller.***


Out of the box, it detects in BIOS/boot screen. The one I received was manufactured in June 2012 and came with:
- 2 x SFF-8087 to 4xSATA cables
- BIOS: 4.14.00 (June? 2010)
- Firmware: 20.5.1-0003
- Image: 2.70.04-0862


Part 1: Getting it to work in Windows Server 2012 x64 RC.

In Server 2012 on the NAS box, the driver will install fine but will report an error (Device cannot start (Code 10)). The card also does not like something about the mainboard/BIOS/UEFI, I guess its the OptionROM/UEFI implementation.
To fix this, I placed the card into an older PC (Dell Optiplex 755), booted into Win7 and installed the appropriate driver, the card works perfectly.
Using the supplied Raid Web Console 2 software, I updated the board with the latest firmware and placed it back into my new NAS PC.

This now works perfectly in Server 2012. Current firmware version to:
- BIOS: 4.30.00 (26th August 2011)
- Firmware: 20.10.1-0107
- Image: 2.130.354-1664


Part 2: Flashing the 9240-8i (SAS2008 chip) to a 9211-8i.

This worked perfectly for my Intel RS2WC080, the process is pretty much exactly the same for any other variant of the LSI SAS2008 controller, pay attention to your models.
I found these posts very helpful: MasterCATZ firmware update post, 6 Gb/s SAS HBA Instructions.

After reading through these, the process I used was:

1. Created a standard bootable DOS USB Flash Drive (USB drives 4GB and under should work).
2. Downloaded the firmware tools in MasterCATZ post and extracted to the USB drive.
3. Download the latest LSI SAS9211-8i firmware, Phase 14 in this case and extracted to desktop.
4. Copied these files to the USB drive (and overwrote where needed): "2118it.bin", "sas2flsh.exe" (MUST BE DOS VERSION), "mptsas2.rom".
5. Place the RAID card into the old PC and booted to USB.
6. Save original sbr (serial boot rom) by typing:
megarec -readsbr 0 backup.sbr (put this backup in a safe place once you're done with the whole process)
7. Write an empty sbr file to controller:
megarec -writesbr 0 empty.bin
8. Erase controller flash:
megarec -cleanflash 0
9. Reboot PC back into USB drive.
10. Set controller to 6GB/s mode:
sas2flsh -o -e 6
11. This will then ask for a firmware version, this is the same name as the updated .bin file:
2118it.bin
12. Flash the controller to new firmware with IT-mode:
sas2flsh -o -f 2118it.bin -b mptsas2.rom
13. Program SAS address in IT-mode where 500605b********* is the code on the green sticker on your RAID card without the "-":
sas2flsh -o -sasadd 500605b*********
14. Place the card back into the NAS box and boot to windows.

Windows Server 2012 x64 RC automatically detected this as "LSI Adapter, SAS2 2008 Falcon" and installed the correct driver.


I hope this information can help someone in the same situation as me.
 
Status
Not open for further replies.
Top