Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

install URbackup in a jail

cellardoor

Newbie
Joined
Jul 21, 2017
Messages
12
If you use this way of starting urbackup you will not have the ability using:
service urbackupsrv restart or stop or start
I use this startup script in /etc/rc.d/urbackupsrv:

#!/bin/sh
. /etc/rc.subr
name=urbackupsrv
rcvar=urbackupsrv_enable
command="/usr/local/bin/${name}"
command_args="run -d -g 104857600 -u root"
start_precmd="cd /usr/local/var"
load_rc_config $name
run_rc_command "$1"

To get it run:

nano /etc/rc.d/backupsrv

than copy/paste the script into this file, save and exit.

than give executive permission to the script with:

chmod +x /etc/rc.d/urbackupsrv

You have to enable urbackupsrv in /etc/rc.conf with

nano /etc/rc.conf

and add the line:

urbackupsrv_enable="YES"

save and exit

service urbackupsrv restart should work.

Did anybody solved the the problem of not beeing able to
mount raw images if running urbackup in an iocage jail
using copy-on-write raw image backups with ZFS?

It is working and for every backup wether file or image it
creates an new dataset but I cannot mount it.
 

cellardoor

Newbie
Joined
Jul 21, 2017
Messages
12
Thanks for the reply.
I know that we have to leave the normal path to do this.
But we are on zfs. Perhaps there is a new way to discover.
Make a copy and set it as share or mount it in Proxmox
and ..... there are much more skilled people here arround than me.
As far as I know: the server and client port will install
urbackup only in the normal way.

uh.. sorry i am totally blind.
i will try:
https://forums.urbackup.org/t/can-a-backup-file-in-raw-format-be-started-directly-by-qemu-kvm/4884
sorry again
 
Last edited:

hervon

FreeNAS Experienced
Joined
Apr 23, 2012
Messages
230
ByteNick. Did you install it in a warden jail (old way) or in a iocage jail (new GUI) ? I have it in a warden. I know in the future i'll to migrate to iocage.
 

hervon

FreeNAS Experienced
Joined
Apr 23, 2012
Messages
230
Last edited:
Joined
Mar 4, 2019
Messages
7
If you use this way of starting urbackup you will not have the ability using:
service urbackupsrv restart or stop or start
I use this startup script in /etc/rc.d/urbackupsrv:

#!/bin/sh
. /etc/rc.subr
name=urbackupsrv
rcvar=urbackupsrv_enable
command="/usr/local/bin/${name}"
command_args="run -d -g 104857600 -u root"
start_precmd="cd /usr/local/var"
load_rc_config $name
run_rc_command "$1"

To get it run:

nano /etc/rc.d/backupsrv

than copy/paste the script into this file, save and exit.

than give executive permission to the script with:

chmod +x /etc/rc.d/urbackupsrv

You have to enable urbackupsrv in /etc/rc.conf with

nano /etc/rc.conf

and add the line:

urbackupsrv_enable="YES"

save and exit

service urbackupsrv restart should work.

Did anybody solved the the problem of not beeing able to
mount raw images if running urbackup in an iocage jail
using copy-on-write raw image backups with ZFS?

It is working and for every backup wether file or image it
creates an new dataset but I cannot mount it.
I did exacly as you instructed and it was throwing an error "cd /usr/local/var" does not exist.
I basically don't know what im doing, but changed var to bin and it finaly seems to work.

Should I set in dataset permissions any user/group?
Also in /usr/local/etc/urbackup/urbackupsrv.conf should user be 'root' or as default 'urbackup'?
 
Joined
Jul 11, 2019
Messages
2
Any way to install the last version of Freenas ?
I can not make the Jail manual ... (fail to download urbackup)
 

hervon

FreeNAS Experienced
Joined
Apr 23, 2012
Messages
230
I'm on UrBackup 2.4.3 beta right now. Picked it from this link
 
Joined
Jul 11, 2019
Messages
2
Its compatible with 11.2.U5?
I just made a new FreeNas server to backup 3-4 windows 10 pcs and I am looking for a basic backup solution...
 

hervon

FreeNAS Experienced
Joined
Apr 23, 2012
Messages
230
Yep. I'm on FreeNAS-11.2-U5. No issue here.
 

hervon

FreeNAS Experienced
Joined
Apr 23, 2012
Messages
230
FYI I'm on 11.2-U6 running the latest server beta 2.4.8 and everything works fine. Urbackup rules. ;-)
 

hervon

FreeNAS Experienced
Joined
Apr 23, 2012
Messages
230
Yet another update. I'm on 11.2-U6 running the latest server 2.4.9 (non beta) and everything works fine.
 
Top