Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

[HowTo] Load Cycles der Festplatten begrenzen

ringhut

Newbie
Joined
Sep 17, 2013
Messages
10
Es gibt ein FreeDos Tool names UBCD mit dem man die Intellipark Funktion in der Firmware der Platte Auschalten bzw. von 8sec auf z.b. 3760 sec. stellen kann und somit die Load-Cyklen bei WD Festplatten komplett minimieren kann.

Man geht wie folgt vor:

1. Iso Download LINK!

2. Iso auf CD Brennen

3. Alle Festplatten trennen bis auf eine die man ändern möchte, da das Tool nur eine HDD maximal bearbeiten kann.

4. Von der CD Booten und im BootLoader dann das freeDos starten.

5. Anschliesend auf Launch -> HDD Device Info and Managment -> und dann ganz unten das WDIDLE3 Tool starten.

6. Mit dem Befehl: "wdidle3 /r" kann die bisher eingestellte Parkzeit eingesehen werden (meist 8.00 Sec.).
Mit"wdidle3 /d" kann man die Funktion komplett deaktivieren. Das heißt der Lesekopf fährt bei nicht Benutzung erst nach 62 Minuten in die Parkstellung.
Mit"wdidle3 /s 300" Z.B. kann man die Sekunden erhöhen bis der Kopf bei nicht Benutztung in die Parkstellung fährt. (300sec = 5min) (default 8)

7.Mit STRG+ALT+Entf Neustarten und bzw. andere Paltte anschließen.

Es wird nur die Firmware der Platte abgeändert! Ich habe mit dieser Methode alle meine 12 WD Platten modifiziert und seitdem hat sicht der Load-Cyklen Zähler nicht mehr bewegt und bei diesem Eingriff gingen keine Daten verloren!

Wichtig: BIOS bei dieser Aktion auf IDE stellen!!

Bei Fragen einfach melden.

Viel Spass
 

jensr

Newbie
Joined
Oct 15, 2013
Messages
21
Hi,

also mit Version 9.1.1 scheint das problem noch nicht erledigt zu sein. ich hab heute mittag ne komplett neue wd red eingebaut und habe nach
Power_On_Hours - 10

schon sagenhafte 290 load cycles ;(

gibt es hier jetzt schon eine zuverlässige Lösung für?
 

warri

FreeNAS Guru
Joined
Jun 6, 2011
Messages
1,193
Das Problem ist nicht FreeNAS, sondern die WD Firmware - zumindest bei den alten 2 TB Green Laufwerken.

Das wdidle Tool funktioniert jedoch auch bei neueren Modellen. Habe irgendwo gelesen, dass die Reds mit /S300 statt /D konfiguriert werden sollten.
 

ringhut

Newbie
Joined
Sep 17, 2013
Messages
10
Kannst ja einmal mit "wdidle3 /r" auslesen.
Da die WD RED auch über die IntelliPower verfügen haben auch diese eine IdleParkzeit von 120 sec. in der Firmware eingestellt.
Kann mit wdidle auf bei dieser Serie auch geändert werden.
 

jensr

Newbie
Joined
Oct 15, 2013
Messages
21
hi ihr beiden, danke dafür. ich probier das morgen mal aus.

blöde frage: die daten die auf der platte sind können ja drauf bleiben oder sollte ich das vorher wegsichern?

das tool ist ja nen DOS tool also frag ich da lieber nach ;)
 

ringhut

Newbie
Joined
Sep 17, 2013
Messages
10
Normalerweise passiert da nix da nur die Firmware angerührt wird.
Am besten du berichtest hier davor was von Haus aus eingestellt ist.
 

jensr

Newbie
Joined
Oct 15, 2013
Messages
21
ok passt ich lad mir das tool und mach nen ersatz usb stick bootfähig und starte dann von dem mal.

weiß allerdings nicht ob ich es morgen schaff - melde mich aber in jedem fall

danke schonmal
 

jensr

Newbie
Joined
Oct 15, 2013
Messages
21
huhu,

irgendwie hats mir doch keine ruhe gelassen. ich habe eben nachgesehen und er sagt:
Model: WDC WD30EFRX-68EUZN0
Serial: WD-WMC4n1099701
Idle3 Timer is enabled and set to 8.000 seconds.

also sollte ich das dann mit /S[<Timer>] oder gar /D ganz abschalten?

vielen dank im vorraus
jens
 

warri

FreeNAS Guru
Joined
Jun 6, 2011
Messages
1,193
Ich würde erstmal mit /S300 rangehen und dann beobachten, ob immer noch zu viele Load Cycles entstehen.
 

jensr

Newbie
Joined
Oct 15, 2013
Messages
21
morgen,

so ich hab jetzt den timer auf die 300 also 5 minuten gesetzt. daten sind auch noch alle da und jetzt warte ich mal ne zeit lang und beobachte wie sich das ganze verhält.

EDIT: so ich hab das system jetzt eine stunde laufen gehabt. gestartet hab ich mit 415 llc´s und nach einer stunde ist der wert nur um 2 also auf 417 llc´s gestiegen.

ich habe das wdidle tool in der version 1.05 genutzt falls jemand das selbe problem mit dem platten hat.

danke euch für eure hilfe ;)
 

ringhut

Newbie
Joined
Sep 17, 2013
Messages
10
Schön das es funktioniert hat :D
 
Joined
Dec 3, 2013
Messages
5
Danke für die Anleitung,
ging alles gut. Meine WD black hatte offensichtlich vom Werk schon die Einstellung /d, die red hatten aber auch 8.000 s.
Als Startdisk ging die Software vom Link nicht, ich habe dort geladen
http://www.ultimatebootcd.com/

:)
 

THX

Newbie
Joined
Dec 6, 2013
Messages
28
Dankefür diesen Threat. Meine neue (diese Woche geordert) WD RED hatte schon 800 LCs.
Hätte ich das hier nicht zufällig gelesen, wer weiß wie lange die gehalten hätte.
 

mka

FreeNAS Experienced
Joined
Sep 26, 2013
Messages
107
Danke für die Hinweise. Ich dachte ursprünglich das Problem beträfe nur die WD Green Serie. Ich habe mittlerweile komplett auf WD Red umgestellt und dachte die wäre auch für Dauerbetrieb ausgelegt. :)

Ich frage mich gerade wie sehr das aber wirklich ein Problem ist. Bei 600.000 spezifizierten Load/Unload Cycle counts sind es etwa 330 Stück pro Tag bei 5 Jahren Nutzungshorizont. Ich werde das daheim mal überprüfen aber vermute meine Platten bleiben unter diesem Wert. Mein NAS verbringt fast den ganzen Tag in Ruhe und die Spindown Zeit der Festplatten habe ich auf 30min aktuell angesetzt. Dann wird meist abends darauf zugegriffen, dann sequentiell via Plex für eine Zeitspanne X dauerhaft. Normalerweise sollten da keine LoadCycles entstehen. Außer es wird immer soviel gecached, dass die Festplatten 8sek nichts zu tun haben (oder je nach Default Wert der RED). Das werde ich mal überprüfen, halte es aber nicht für wahrscheinlich.
Einmal die Woche produzieren diverse Backupdienste ebenfalls eine sequentielle Last, wo die Festplatten ebenfalls nicht viel Pausen haben sollten. Bei einem leichten Mischbetrieb über den ganzen Tag hinweg kann ich mir gut vorstellen, dass die durch den Himmel gehen. Aber bei NAS Videostreamingnutzung?

Wie unterscheidet sich denn der Energiebedarf der laufenden vs. der geparkten Festplatten vs. der spindown Platte?

EDIT: In der spec dies gefunden: 4.5W/3.3W/0.4W ... ist der Wert für Read/Write identisch mit "ungeparkt"? Die 0.4W werden sich wohl auf spindown beziehen.

Lassen sich nebenbei die Load Cycles im FreeNAS WebGUI Reporting Menu grafisch darstellen?
 
Joined
Nov 21, 2013
Messages
8
Hallo zusammen,
ich habe 3 WD Reds (3TB, WD30EFRX) bei mir im NAS (HP N40L, FreeNAS-9.2.0-RELEASE-x64) verbaut und habe bei 2 Festplatten auch das Problem, das der Load Cycles Wert viel zu hoch ist. Ich wollte jetzt per wdidle3 bei allen Festplatten den Wert auf 300 setzen.

Mir stellt sich jetzt nur eine Frage:
Welche Einstellungen habt ihr bei HDD-Standby, APM und Acoustic Level Enable, SMART eingestellt?
Habt ihr die Einstellungen wie Rolfhartmut (Siehe Seite 1, Post 1) genommen oder andere?

Die Einstellungen sind bei mir momentan:
Transfer Mode: Auto
HDD Standby: Always ON
APM: 192
Acoustic Level: Disabled
Enable SMART: True

Ich danke Euch schon einmal für die Hilfe!

LG,
Christian
 

Retrogamer

Newbie
Joined
Jun 24, 2014
Messages
19
Also ich habe in meinem NAS

3x WD Red 3TB (neu in dem NAS)
1x Seagate irgendwas 3TB (älter)

Folgende Settings:
Standby: Dauerbetrieb
Energieverwaltung: Deaktiviert
Lärmunterdrückung: Deaktiviert
SMART: aktiviert (Haken gesetzt)

Die WDs haben jetzt nach knapp 3500h 125 Cycles.

Hier mal die Smartwerte einer der Platten:
Code:
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG    VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate    0x002f  200  200  051    Pre-fail  Always      -      0
  3 Spin_Up_Time            0x0027  174  174  021    Pre-fail  Always      -      6283
  4 Start_Stop_Count        0x0032  100  100  000    Old_age  Always      -      8
  5 Reallocated_Sector_Ct  0x0033  200  200  140    Pre-fail  Always      -      0
  7 Seek_Error_Rate        0x002e  200  200  000    Old_age  Always      -      0
  9 Power_On_Hours          0x0032  096  096  000    Old_age  Always      -      3517
10 Spin_Retry_Count        0x0032  100  253  000    Old_age  Always      -      0
11 Calibration_Retry_Count 0x0032  100  253  000    Old_age  Always      -      0
12 Power_Cycle_Count      0x0032  100  100  000    Old_age  Always      -      8
192 Power-Off_Retract_Count 0x0032  200  200  000    Old_age  Always      -      4
193 Load_Cycle_Count        0x0032  200  200  000    Old_age  Always      -      125
194 Temperature_Celsius    0x0022  122  113  000    Old_age  Always      -      28
196 Reallocated_Event_Count 0x0032  200  200  000    Old_age  Always      -      0
197 Current_Pending_Sector  0x0032  200  200  000    Old_age  Always      -      0
198 Offline_Uncorrectable  0x0030  200  200  000    Old_age  Offline      -      0
199 UDMA_CRC_Error_Count    0x0032  200  200  000    Old_age  Always      -      0
200 Multi_Zone_Error_Rate  0x0008  200  200  000    Old_age  Offline      -      0
 

lnix

Newbie
Joined
Aug 16, 2014
Messages
29
wie kann ich mir denn unter FreeNAS die Load Cycles meiner Festplatten anzeigen lassen?
 

warri

FreeNAS Guru
Joined
Jun 6, 2011
Messages
1,193
Nur über die Command Line mit

Code:
smartctl -a /dev/adaX | grep Load_Cycle_Count


X jeweils mit der Festplattennummer ersetzen.
 

lnix

Newbie
Joined
Aug 16, 2014
Messages
29
Ich habe dies mal ausprobiert:

[root@freenas] ~# smartctl -a /dev/ada0 | grep Load_Cycle_Count

193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 27

[root@freenas] ~# smartctl -a /dev/ada1 | grep Load_Cycle_Count

193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 29

[root@freenas] ~# smartctl -a /dev/ada2 | grep Load_Cycle_Count

193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 27

[root@freenas] ~# smartctl -a /dev/ada3 | grep Load_Cycle_Count

193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always - 30


Das sieht doch ganz gut aus oder? Der Wert ist doch 27-30 oder? Mein NAS läuft seit ca. 1 Woche (nach 30min gehen meine Platten in Standby)
 
Top