Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

How to fix "cannot receive aclmode property on <poolname>: invalid property value" when replicating to linux

Joined
May 1, 2019
Messages
5
Thanks
1
#1
This is not a question but an answer, as I stumbled several times over this problem and eventually found what I needed on google, but it was always very difficult to locate.
So for everyone else who wants to replicate from their FreeNAS to a linux machine and who gets this error:

cannot receive aclmode property on <poolname>: invalid property value

The solution is to run this on your NAS machine:

zfs set aclmode=discard <poolname>

Also, don't forget to make sure that you have the lz4c command installed on the receiving side. On debian-based systems it's the package liblz4-tool, an archlinux it's the lz4 package.

Hopefully this will save someone some headaches and time.

--Marenz
 

scurrier

FreeNAS Experienced
Joined
Jan 2, 2014
Messages
269
Thanks
11
#2
How would this compare to using the -x aclmode option for the zfs recv command? This will strip the aclmode property out of the stream before "receiving" it, avoiding errors.
 
Top