Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

FTP Authentication

Western Digital Drives - The Preferred Drives of FreeNAS and TrueNAS CORE
Status
Not open for further replies.

loweredhemi

Newbie
Joined
Jun 7, 2011
Messages
2
I'm trying to set up an FTP connection to the server. I am using DYNDNS and have it set up and I'm able to find the machine.

The problem is that I can't log on to it. Every user name and password I put in does not work.

Is there a place to set up the log in information for the FTP service?

Thanks.
 
B

Bohs Hansen

Guest
I'm having similar issue. My guess its a user rights problem, somewhere...

My users work fine from "normal windows" via CIFS. But if I try to connect via FTP, I get "530 Login incorrect" on every user inclusive the admin account. (only locally via IP)

[edit]
Oh, and I have the same problem via SSH, from the winscp logfile i get these returns, maybe they'll help identify the problem.
Code:
. 2011-06-08 12:51:22.955 Disconnected: No supported authentication methods available
* 2011-06-08 12:51:22.960 (ESshFatal) Disconnected: No supported authentication methods available
 

esamett

Senior Member
Joined
May 28, 2011
Messages
338
+1, but I am too much of a NOOB to realize it wasn't my fault. lol.
 
B

Bohs Hansen

Guest
found the problem, for my case atleast.

It was the "Home Directory" default "/nonexistent" that caused the error. setting it to my mount name "/mnt/jcube1/" and suddenly ftp accepts my login details.
 

loweredhemi

Newbie
Joined
Jun 7, 2011
Messages
2
Okay,

So I have been able to log in through FTP as long as I'm on the local network and go to the local address "ftp://192.168.1.9:port#"

Now when I try to log in through my DYNDNS address and enter the same log in info it won't pull up the files.
It sees the machine and asks for a user and password and seems to take it but then nothing.
I can't seem to get to the directory.
 

esamett

Senior Member
Joined
May 28, 2011
Messages
338
i couldn't login to ftp from my local network
 

Seb

Newbie
Joined
Sep 5, 2011
Messages
1
found the problem, for my case atleast.

It was the "Home Directory" default "/nonexistent" that caused the error. setting it to my mount name "/mnt/jcube1/" and suddenly ftp accepts my login details.
Thanks a lot, in my case it was the same problem !
 

jallenjens

Neophyte
Joined
Jun 25, 2012
Messages
10
I'm having the same issue as loweredhemi where if I disable anon access, I can login but can't see any of the folders or files in the home directory. Anyone found a solution for that issue?

EDIT: I was able to get it working both with local users and active directory users. The permissions on my home directories were wrong. Fixing them fixed the issue.
 
Status
Not open for further replies.
Top