Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

FreeNAS 11 Debian 9 VM installation GUI issue

ovalcoconut

Junior Member
Joined
Feb 11, 2018
Messages
12

The above image is a problem I'm getting when connecting to my debian VM via VNC. This happens on all resolutions Ive tried: 1920x1080, 1024x768, 1280x960, and 1280x1024. This happens when I connect using VNC viewer, and the web VNC that FreeNAS provides.

My system specs are:
Intel(R) Core(TM) i5-4570 CPU @ 3.20GHz
16222MB RAM
FreeNAS-11.1

My VM specs are:
1 Virtual CPU
4096 MiB RAM
50 GB zvol
Debian 9.3.0-amd64-cinnamon.iso

When I press the up and down arrow keys, the selection changes, so the issue seems to be with the how it's being displayed. I pressed the right arrow key to see if anything happened, and the OS started, and put me into the desktop successfully. With perfectly functioning graphics, and cinnamon did it's job with no issues. This issue stayed through multiple restarts.

I really don't know where this issue is coming from. Once Debian boots up, everything is fine. The console echo displays properly, it's just this menu that I can't read.
Is it the fault of Debian, FreeNAS, or myself?
I can provide additional pictures/information if needed.
 
Last edited by a moderator:

KrisBee

Neophyte Sage
Joined
Mar 20, 2017
Messages
1,083
There have been a few other threads about buggy VNC in FreeNAs 11.1-U1. About the only way to get a debian install working at the moment is to use a netinstall iso in text mode.
 

bladblad

Neophyte
Joined
Feb 5, 2018
Messages
11
It will be resolve in next patch. Maybe 5 or more days ;)

Envoyé de mon SM-A520F en utilisant Tapatalk
 

ovalcoconut

Junior Member
Joined
Feb 11, 2018
Messages
12
Well that's a relief, I had thought I messed up somewhere in my settings. At least I'm not the only one experiencing this. Thanks.
 

ChrisChros

Member
Joined
Nov 24, 2018
Messages
135
Hi guys,
tried also to install the debian Netinst iso with the same result as @ovalcoconut
Is there any solution to fix this.

Using Freenas 11.1-U6.
 

KrisBee

Neophyte Sage
Joined
Mar 20, 2017
Messages
1,083
Hi guys,
tried also to install the debian Netinst iso with the same result as @ovalcoconut
Is there any solution to fix this.

Using Freenas 11.1-U6.
Try setting VNC screen res to 800x600. Once installed, dump VNC in favour of ssh.
 

garypib

Neophyte
Joined
Jun 18, 2019
Messages
5
Thank you, 800x600 worked. However, the issue still exits in FreeNAS-11.2-U5 with other resolutions. I have tried Debian 9 and 10 without success. If it helps to diagnose the issue, V7.8 installs without any problems at higher resolutions through VNC.
 

plissje

Junior Member
Joined
Mar 6, 2017
Messages
16
Hey,
How do you set the 800x600 resolution? Still got the same issue with 11.2 and Debian 10
 

Lucas Rey

Member
Joined
Jul 25, 2011
Messages
147
Hey,
How do you set the 800x600 resolution? Still got the same issue with 11.2 and Debian 10
I found this thread after several searches and I can confirm the 800x600 resolution trick still works.
You have to edit VNC setting on single VM on FreeNAS (under devices).
 

twillkickers

Junior Member
Joined
Jun 3, 2017
Messages
18
I am also having this issue, however I have no idea how to change the resolution in VNC Viewer. I used to change the "Picture Quality" setting to High and it would solve this, but now that doesn't seem to work. Any suggestions?

Also why is VNC so awful? :mad::mad::mad:
 

Lucas Rey

Member
Joined
Jul 25, 2011
Messages
147
I am also having this issue, however I have no idea how to change the resolution in VNC Viewer. I used to change the "Picture Quality" setting to High and it would solve this, but now that doesn't seem to work. Any suggestions?

Also why is VNC so awful? :mad::mad::mad:
You don't have to change resolution in VNC Client, you have to change it on server side. Go to FreeNAS Lovelace GUI. Then on each virtual machines you have, click on "device" menu. then on VNC device click on the 3 dots on the right and choose edit. Here you have the resulution, setup it at 800x600. Thant's it.
 

greinbold

Neophyte
Joined
Apr 6, 2019
Messages
9
Same issue here, but set the VNC device resolution to 800x600, does not solve the issue. I reported a bug since Nov 27 2019, but no fix, no workaround. I'm the only one which experience this issue?
 

QS639X2dq

Newbie
Joined
Mar 28, 2020
Messages
3
So, I was able to have success, after facing the same exact issue, by doing the following:

FreeNAS > Virtual Machines > (debian VM) > Devices > VNC > Uncheck the web GUI checkbox
FreeNAS > Virtual Machines > (debian VM) > Devices > VNC > Set resolution to 800x600
RealVNC > Expert Settings > Scale > 800x600
 

cen

Member
Joined
Jul 12, 2014
Messages
29
11.1.U7 still has the same problem, the resolution trick did work for me (RealVNC) but remember to restart the VM first.
 

polygonalsnow

Junior Member
Joined
Nov 5, 2019
Messages
15
Chiming in that this is still an issue with 11.3-RELEASE, and that the 800x600 workaround still works. All other resolutions seem broken
 
Top