Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

FreeNAS-11.0-RELEASE VM change the bridge mtu

Joined
Jan 24, 2017
Messages
7
Thanks
0
#1
can't start a VM: bridge0 do need a mtu of 9000, because the nic (lagg0 / lacp) has a mtu of 9000.

"bridge0: invalid MTU: 9000(lagg0) != 1500"

Where can I change the mtu for bridge0?

Code:
% ifconfig bridge0
bridge0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 02:da:ca:44:0c:00
	nd6 options=9<PERFORMNUD,IFDISABLED>
	groups: bridge 
	id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
	maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
	root id 00:00:00:00:00:00 priority 0 ifcost 0 port 0
	member: tap0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
			ifmaxaddr 0 port 5 priority 128 path cost 2000000
 

dlavigne

Storage Engineering
Administrator
Moderator
iXsystems
Joined
May 24, 2011
Messages
11,667
Thanks
1,019
#2
Please create a feature request at bugs.freenas.org and post the issue number here.
 
Joined
Sep 16, 2019
Messages
3
Thanks
0
#3
Would someone from iX be able to confirm if this is still an issue?

I am trying to create the following network topology:

* A physical device ix0
* A VLAN interface, vlan101, with parent interface ix0
* A bridge, bridge101, with member vlan101
* A jail on the VLAN by using vnet with bridge101

NOTE: I want an MTU of 9000 for ALL.

First, I create the VLAN interface using the GUI which results in:

Code:
root@freenas[~]# ifconfig vlan101
vlan101: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 9000
    options=600703<RXCSUM,TXCSUM,TSO4,TSO6,LRO,RXCSUM_IPV6,TXCSUM_IPV6>
    ether 00:17:3c:03:8c:d8
    inet 192.168.101.1 netmask 0xffffff00 broadcast 192.168.101.255
    nd6 options=9<PERFORMNUD,IFDISABLED>
    media: Ethernet autoselect (1000Base-KX <full-duplex,rxpause,txpause>)
    status: active
    vlan: 101 vlanpcp: 0 parent interface: ix0
    groups: vlan
root@freenas[~]#


Then, I create a bridge using the GUI which results in:

Code:
root@freenas[~]# ifconfig bridge101
bridge101: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 9000
    ether 02:17:68:87:cf:65
    nd6 options=9<PERFORMNUD,IFDISABLED>
    groups: bridge
    id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
    root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    member: vlan101 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 6 priority 128 path cost 2000
root@freenas[~]#


After the bridge creation I see the following message on the terminal:

Code:
bridge101: Ethernet address: 02:17:68:87:cf:65
bridge101: can't disable some capabilities on vlan101: 0x400


Finally, I create a jail that uses vnet by setting the jail advanced configuration 'Network properties' -> 'interfaces' to vnet0:bridge101.

However, on boot the following messages appear:

Code:
epair0a: Ethernet address: 02:ba:d0:00:0a:0a
epair0b: Ethernet address: 02:ba:d0:00:0b:0b
bridge101: invalid MTU: 9000(vnet0.1) != 1500


The MTU for bridge101 is, in fact, not set to the expected 9000:

Code:
root@freenas[~]# ifconfig bridge101
bridge101: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
    ether 02:17:68:87:cf:65
    nd6 options=9<PERFORMNUD,IFDISABLED>
    groups: bridge
    id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
    root id 00:00:00:00:00:00 priority 0 ifcost 0 port 0
    member: vlan101 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 6 priority 128 path cost 2000
root@freenas[~]#


The network interface still matches the values set on creation if I edit the bridge interface. Confusingly, clicking 'SAVE' here applies the expected MTU:

Code:
root@freenas[~]# ifconfig bridge101
bridge101: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 9000
    ether 02:17:68:87:cf:65
    nd6 options=9<PERFORMNUD,IFDISABLED>
    groups: bridge
    id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15
    maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200
    root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0
    member: vlan101 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>
            ifmaxaddr 0 port 6 priority 128 path cost 2000
root@freenas[~]#


I realize this thread is for a VM but it appears we are seeing the same issue.

TL;DR Is there a way to persistently set the MTU of a bridge from the GUI?
 
Joined
Sep 16, 2019
Messages
3
Thanks
0
#5
Thanks for the response! I tried this with an 11.3 build but get the same results.

This is the bridge creation:
bridge-creation.png


After boot I get the error:
Code:
bridge101: invalid MTU: 9000(vnet0.1) != 1500


And I can go back and check the configuration for the bridge is set as expected:
bridge-confirmation.png


Again, clicking 'SAVE' here results in the bridge changing to the expected MTU.

Is this the UI support you were referring to?
 
Top