Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Failed pool copy process

Joined
Jul 14, 2016
Messages
6
Thanks
0
#1
Hi all,

I've got a pool that's been running 8x3TB drives in RAIDZ2 for a while now /mnt/mainarray), and I'm replacing it with a 3x 10TB Z1 (/mnt/v2array) pool that I will eventually expand with more 3x10TB vdevs, but first I need to copy the first pool entirely over the new pool. This is
FreeNAS-11.2-BETA1 (Build Date: Jul 6, 2018 22:29). 16 cpu / 72GB ram. Drives are connected via Lenovo SA120 DAS.

After doing some research I ran screen, and then issued the following command..


zfs snapshot -r mainarray@moving
zfs send -R mainarray@moving | zfs receive -F v2array

This seemed to be working, ~18 hours later I check and the screen session is no longer existing, and the space consumed on the new pool seems to roughly match the space consumed by the old pool... but, there are directories missing.. so I SSH in and look around, directory structure exists, but no files..

Then I notice directories on the new pool disappearing, and the consumed space (as reported by the GUI is shrinking.. by TB's), almost like it's reverting to a pre-copy state.

The only I noticed in the logs at the bottom of the UI was this, at midnight..

Jun 13 00:00:00 greenleo syslog-ng[8555]: Configuration reload request received, reloading configuration;
Jun 13 00:00:00 greenleo syslog-ng[8555]: Configuration reload finished;

I'm assuming since the screen session died, something killed this process.

What is the best next steps? Should I destroy the new pool and re-create it to be safe? Did I forget to do anything here, or was this just potentially bad luck? What is this config reload, and should I prevent that from running during the copy process?

THanks!

Edit - Since I've posted this, the new pool has completely wiped itself clean from that process, like it undid the restore operation by itself.
 
Joined
Jul 14, 2016
Messages
6
Thanks
0
#3
Did your replication ever complete?
Thanks for asking! It actually failed twice, both random reboots.. I realized I was running a beta version of FreeNAS so just upgraded to the full version. After that the copy process completed fine. Took ~24 hours for 16TB but it did finish!
 
Top