Error opening file for writing; filename='/dev/console', error='Device not configured ... Again...

Joined
Mar 11, 2019
Messages
2
Thanks
0
#1
Hello,

I've been following this forum for years, but i've had one problem with Freenas, that has been there since forever, so today I registered and thought I would share my thoughts.

Code:
Mar 11 14:18:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:19:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:20:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:21:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:22:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:23:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:24:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:25:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:26:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:27:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'


Search results:
https://redmine.ixsystems.com/issues/9776
https://www.ixsystems.com/community...-file-for-writing-filename-dev-console.45230/
https://www.ixsystems.com/community...slog-ng-error-opening-file-for-writing.41987/
https://www.ixsystems.com/community...-file-for-writing-filename-dev-console.62887/
https://www.ixsystems.com/community/threads/freenas-11-0-rc3-freezing.54929/

Seem's like it never really got solved.

To me it seems like the problem came after I restored the settings a few years ago.

If you restart the syslog-ng in the console it stops outputting the error and it seems to work fine again.

root@fstor:[~]# service syslog-ng restart

Mar 11 14:34:21 fstor syslog-ng[1187]: Error opening file for writing; filename='/dev/console', error='Device not configured (6)'
Mar 11 14:35:18 fstor syslog-ng[1187]: syslog-ng shutting down; version='3.18.1'
Mar 11 14:35:18 fstor syslog-ng[5669]: syslog-ng starting up; version='3.18.1'


So for now I have a small script it runs on the boot to solve this problem. Maybe the syslog-ng starts to fast, before the /dev/console is ready? idk

Maybe one of you have some suggestion what it could be?

PS: This problem exist on both the FreeNAS snapshot version and the lastest stable version.
 
Joined
Mar 11, 2019
Messages
2
Thanks
0
#3
We have 2 servers. Both servers output this error:

Our production server: 11.2-U2.1
And our test server: FreeNAS-11.3-MASTER-201903110828
 

dlavigne

Storage Engineering
Administrator
Moderator
iXsystems
Joined
May 24, 2011
Messages
10,671
Thanks
884
#4
Please create a report at redmine.ixsystems.com and post the issue number here.
 
Top