Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

configuring jails for IPv6

Status
Not open for further replies.

blubberor

Member
Joined
Jan 31, 2016
Messages
40
Hello everybody.
there are and there will be more and more people having prpoblems with this.

I am unable configure freenas 11.2 beta for assigning real IPv6 for the jails.

Under network I created an interface re0 w ith the name IPv6 and autoconfigure for IPv4 (DHCP) and IPv6

now I am stuck though with configuring the jails.
These are my iocage and ifconfig outputs:

Code:
[root@freenas ~]# iocage list

+-----+-----------+-------+--------------+------+

| JID |   NAME	| STATE |   RELEASE	| IP4  |

+=====+===========+=======+==============+======+

| 5   | emby	  | up	| 11.1-RELEASE | DHCP |

+-----+-----------+-------+--------------+------+

| 1   | nextcloud | up	| 11.1-RELEASE | DHCP |

+-----+-----------+-------+--------------+------+

| -   | plex	  | down  | 11.1-RELEASE | DHCP |

+-----+-----------+-------+--------------+------+

[root@freenas ~]# ifconfig

re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>

		ether d0:50:99:76:a2:a8

		hwaddr d0:50:99:76:a2:a8

		inet6 fc12::a110:92ff:fe12:b1h8%re0 prefixlen 64 scopeid 0x1

		inet6 3e12:132:542:f7a0:a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet6 fc12::a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet 192.168.178.21 netmask 0xffffff00 broadcast 192.168.178.255

		nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>

		media: Ethernet autoselect (1000baseT <full-duplex,master>)

		status: active

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384

		options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>

		inet6 ::1 prefixlen 128

		inet6 fc12::1%lo0 prefixlen 64 scopeid 0x2

		inet 127.0.0.1 netmask 0xff000000

		nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

		groups: lo

bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

		ether 02:af:67:da:6e:00

		nd6 options=1<PERFORMNUD>

		groups: bridge

		id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15

		maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200

		root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0

		member: vnet0:5 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 5 priority 128 path cost 2000

		member: vnet0:1 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 4 priority 128 path cost 2000

		member: re0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 1 priority 128 path cost 20000

vnet0:1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		description: associated with jail: nextcloud

		options=8<VLAN_MTU>

		ether 02:ff:60:ba:b5:81

		hwaddr 02:28:10:00:04:0a

		nd6 options=1<PERFORMNUD>

		media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)

		status: active

		groups: epair

vnet0:5: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		description: associated with jail: emby

		options=8<VLAN_MTU>

		ether 02:ff:60:79:aa:5f

		hwaddr 02:28:10:00:05:0a

		nd6 options=1<PERFORMNUD>

		media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)

		status: active

		groups: epair

[root@freenas ~]# ifconfig -a

re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>

		ether d0:50:99:76:a2:a8

		hwaddr d0:50:99:76:a2:a8

		inet6 fc12::a110:92ff:fe12:b1h8%re0 prefixlen 64 scopeid 0x1

		inet6 3e12:132:542:f7a0:a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet6 fc12::a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet 192.168.178.21 netmask 0xffffff00 broadcast 192.168.178.255

		nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>

		media: Ethernet autoselect (1000baseT <full-duplex,master>)

		status: active

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384

		options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>

		inet6 ::1 prefixlen 128

		inet6 fc12::1%lo0 prefixlen 64 scopeid 0x2

		inet 127.0.0.1 netmask 0xff000000

		nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

		groups: lo

bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

		ether 02:af:67:da:6e:00

		nd6 options=1<PERFORMNUD>

		groups: bridge

		id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15

		maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200

		root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0

		member: vnet0:5 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 5 priority 128 path cost 2000




I am getting confused now where to enter the correct settings for net iocage network and where or what I have to clone.
I am use more and more people will come up with these problems so having a detailed thread that helps would be highly appreciated.

I changed all IPs in the thread so that no information gets lost. so no worries.

Thanks so much.
B
 
Last edited:

passuff

Newbie
Joined
Oct 3, 2018
Messages
2
Hello everybody.
there are and there will be more and more people having prpoblems with this.

I am unable configure freenas 11.2 beta for assigning real IPv6 for the jails.

Under network I created an interface re0 w ith the name IPv6 and autoconfigure for IPv4 (DHCP) and IPv6

now I am stuck though with configuring the jails.
These are my iocage and ifconfig outputs:

Code:
[root@freenas ~]# iocage list

+-----+-----------+-------+--------------+------+

| JID |   NAME	| STATE |   RELEASE	| IP4  |

+=====+===========+=======+==============+======+

| 5   | emby	  | up	| 11.1-RELEASE | DHCP |

+-----+-----------+-------+--------------+------+

| 1   | nextcloud | up	| 11.1-RELEASE | DHCP |

+-----+-----------+-------+--------------+------+

| -   | plex	  | down  | 11.1-RELEASE | DHCP |

+-----+-----------+-------+--------------+------+

[root@freenas ~]# ifconfig

re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>

		ether d0:50:99:76:a2:a8

		hwaddr d0:50:99:76:a2:a8

		inet6 fc12::a110:92ff:fe12:b1h8%re0 prefixlen 64 scopeid 0x1

		inet6 3e12:132:542:f7a0:a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet6 fc12::a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet 192.168.178.21 netmask 0xffffff00 broadcast 192.168.178.255

		nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>

		media: Ethernet autoselect (1000baseT <full-duplex,master>)

		status: active

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384

		options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>

		inet6 ::1 prefixlen 128

		inet6 fc12::1%lo0 prefixlen 64 scopeid 0x2

		inet 127.0.0.1 netmask 0xff000000

		nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

		groups: lo

bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

		ether 02:af:67:da:6e:00

		nd6 options=1<PERFORMNUD>

		groups: bridge

		id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15

		maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200

		root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0

		member: vnet0:5 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 5 priority 128 path cost 2000

		member: vnet0:1 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 4 priority 128 path cost 2000

		member: re0 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 1 priority 128 path cost 20000

vnet0:1: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		description: associated with jail: nextcloud

		options=8<VLAN_MTU>

		ether 02:ff:60:ba:b5:81

		hwaddr 02:28:10:00:04:0a

		nd6 options=1<PERFORMNUD>

		media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)

		status: active

		groups: epair

vnet0:5: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		description: associated with jail: emby

		options=8<VLAN_MTU>

		ether 02:ff:60:79:aa:5f

		hwaddr 02:28:10:00:05:0a

		nd6 options=1<PERFORMNUD>

		media: Ethernet 10Gbase-T (10Gbase-T <full-duplex>)

		status: active

		groups: epair

[root@freenas ~]# ifconfig -a

re0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> metric 0 mtu 1500

		options=82099<RXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_MAGIC,LINKSTATE>

		ether d0:50:99:76:a2:a8

		hwaddr d0:50:99:76:a2:a8

		inet6 fc12::a110:92ff:fe12:b1h8%re0 prefixlen 64 scopeid 0x1

		inet6 3e12:132:542:f7a0:a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet6 fc12::a110:92ff:fe12:b1h8 prefixlen 64 autoconf

		inet 192.168.178.21 netmask 0xffffff00 broadcast 192.168.178.255

		nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>

		media: Ethernet autoselect (1000baseT <full-duplex,master>)

		status: active

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384

		options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>

		inet6 ::1 prefixlen 128

		inet6 fc12::1%lo0 prefixlen 64 scopeid 0x2

		inet 127.0.0.1 netmask 0xff000000

		nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>

		groups: lo

bridge0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500

		ether 02:af:67:da:6e:00

		nd6 options=1<PERFORMNUD>

		groups: bridge

		id 00:00:00:00:00:00 priority 32768 hellotime 2 fwddelay 15

		maxage 20 holdcnt 6 proto rstp maxaddr 2000 timeout 1200

		root id 00:00:00:00:00:00 priority 32768 ifcost 0 port 0

		member: vnet0:5 flags=143<LEARNING,DISCOVER,AUTOEDGE,AUTOPTP>

				ifmaxaddr 0 port 5 priority 128 path cost 2000




I am getting confused now where to enter the correct settings for net iocage network and where or what I have to clone.
I am use more and more people will come up with these problems so having a detailed thread that helps would be highly appreciated.

I changed all IPs in the thread so that no information gets lost. so no worries.

Thanks so much.
B

I have the same issue. No autoconfig option is available for IPv6, just for IPv4... Why?
 
Status
Not open for further replies.
Top