Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Cannot update one jail after upgrading it (the jail) to 11.3.

SeaFox

Newbie
Joined
Aug 6, 2013
Messages
77
I have a small group of jails here:



Jail ID 4 is actually from an official FreeNAS plugin, so ignore it. The others are all plain jails I made to install other services.
The jails have all been on earlier versions of 11.2-RELEASE (I think p9 was most of them). I used the update command on the GUI to bring them all to 11.2p15 at one point.

After I updated to FreeNAS 11.2U7, I upgraded Jail 7 to 11.3 using iocage upgrade -r 11.3-RELEASE jailname and it seemed to work. It updated to what you see here (11.3-RELEASE-p5). Things seems to go smoothly except I got some message at the end saying I needed to restart the jail and run some script to finsh the upgrade? But when I restarted the jail I was told the file referenced did not exist. The jail seemed to suggest the update was done and things were working, so I decided to hold off on anything more at the time.

Later I updated FreeNAS to 11.3, after that I tried updating Jail 8 the same way ( iocage upgrade -r 11.3-RELEASE jailname ). I once again got the message about needing to run something to finish the upgrade which I was unable to. And again things seemed to be fine after that. When it updated, I noticed the jail updated to 11.3-RELEASE-p6 this time.

I tried running the update command from the GUI to bring Jail 7 to the same, but it would not work:


That's all I'm getting.

I've since then updated to FreeNAS 11.3U1.
I just now tried running the same GUI Update command on Jail 8, and seems to have run without error (the patch level did not change, but it seemed to run and update and did not give any errors). But I still cannot update Jail 7 (getting same error). So at this point it looks like Jail 7 is going to be stuck at 11.3-RELEASE-p5. Is anyone else seeing the same error with updating jails? How can I get more useful error info here?
 

wxlsxn

Newbie
Joined
May 19, 2017
Messages
27
I have a small group of jails here:



Jail ID 4 is actually from an official FreeNAS plugin, so ignore it. The others are all plain jails I made to install other services.
The jails have all been on earlier versions of 11.2-RELEASE (I think p9 was most of them). I used the update command on the GUI to bring them all to 11.2p15 at one point.

After I updated to FreeNAS 11.2U7, I upgraded Jail 7 to 11.3 using iocage upgrade -r 11.3-RELEASE jailname and it seemed to work. It updated to what you see here (11.3-RELEASE-p5). Things seems to go smoothly except I got some message at the end saying I needed to restart the jail and run some script to finsh the upgrade? But when I restarted the jail I was told the file referenced did not exist. The jail seemed to suggest the update was done and things were working, so I decided to hold off on anything more at the time.

Later I updated FreeNAS to 11.3, after that I tried updating Jail 8 the same way ( iocage upgrade -r 11.3-RELEASE jailname ). I once again got the message about needing to run something to finish the upgrade which I was unable to. And again things seemed to be fine after that. When it updated, I noticed the jail updated to 11.3-RELEASE-p6 this time.

I tried running the update command from the GUI to bring Jail 7 to the same, but it would not work:


That's all I'm getting.

I've since then updated to FreeNAS 11.3U1.
I just now tried running the same GUI Update command on Jail 8, and seems to have run without error (the patch level did not change, but it seemed to run and update and did not give any errors). But I still cannot update Jail 7 (getting same error). So at this point it looks like Jail 7 is going to be stuck at 11.3-RELEASE-p5. Is anyone else seeing the same error with updating jails? How can I get more useful error info here?
I've had a similar issue but mine occurred without updating jails prior to FreeNAS update. I've since upgraded manually with "iocage upgrade -r 11.3-RELEASE [jailname]". Once that manual upgrade has finished, I've attempted the GUI upgrade again and it "updates" fine without the "Error: b"". It doesn't appear to actually update anything, but the update process finishes without error.
 

Sillyus Sodus

Newbie
Joined
Feb 9, 2016
Messages
14
I have a small group of jails here:



Jail ID 4 is actually from an official FreeNAS plugin, so ignore it. The others are all plain jails I made to install other services.
The jails have all been on earlier versions of 11.2-RELEASE (I think p9 was most of them). I used the update command on the GUI to bring them all to 11.2p15 at one point.

After I updated to FreeNAS 11.2U7, I upgraded Jail 7 to 11.3 using iocage upgrade -r 11.3-RELEASE jailname and it seemed to work. It updated to what you see here (11.3-RELEASE-p5). Things seems to go smoothly except I got some message at the end saying I needed to restart the jail and run some script to finsh the upgrade? But when I restarted the jail I was told the file referenced did not exist. The jail seemed to suggest the update was done and things were working, so I decided to hold off on anything more at the time.

Later I updated FreeNAS to 11.3, after that I tried updating Jail 8 the same way ( iocage upgrade -r 11.3-RELEASE jailname ). I once again got the message about needing to run something to finish the upgrade which I was unable to. And again things seemed to be fine after that. When it updated, I noticed the jail updated to 11.3-RELEASE-p6 this time.

I tried running the update command from the GUI to bring Jail 7 to the same, but it would not work:


That's all I'm getting.

I've since then updated to FreeNAS 11.3U1.
I just now tried running the same GUI Update command on Jail 8, and seems to have run without error (the patch level did not change, but it seemed to run and update and did not give any errors). But I still cannot update Jail 7 (getting same error). So at this point it looks like Jail 7 is going to be stuck at 11.3-RELEASE-p5. Is anyone else seeing the same error with updating jails? How can I get more useful error info here?
Try running:

iocage update [jailname]

from the main shell.

I got an error message complaining about freebsd-update.conf line 1. It turns out that file (in the jail) had a bit chopped off the first line. It should start with "# $FreeBSD:" but mine just started with "D:".

I edited the missing part back in manually in the jail shell using "nano /etc/freebsd-update.conf" and the updates work now.
 

SeaFox

Newbie
Joined
Aug 6, 2013
Messages
77
Try running:

iocage update [jailname]
Code:
root@mittsume[~]# iocage update plex_2
Snapshot: jails/iocage/jails/plex_2@ioc_update_11.3-RELEASE-p5_2020-03-27_03-12-30 created.
Updating jail...

* Updating plex_2 to the latest patch level...
You have a partially completed upgrade pending
Run '/tmp/tmpjtqbqcly install' first.
Run '/tmp/tmpjtqbqcly fetch -F' to proceed anyway.

root@mittsume[~]# /tmp/tmpjtqbqcly install
No updates are available to install.
Run '/tmp/tmpjtqbqcly fetch' first.
root@mittsume[~]# /tmp/tmpjtqbqcly fetch
tmpjtqbqcly: SERVERNAME must be given via command line or configuration file.
root@mittsume[~]#
root@mittsume[~]# /tmp/tmpjtqbqcly fetch -F
tmpjtqbqcly: SERVERNAME must be given via command line or configuration file.
root@mittsume[~]#
root@mittsume[/]# /tmp/tmpjtqbqcly -s update.FreeBSD.org fetch -F
tmpjtqbqcly: Key must be given via -k option or configuration file.



Code:
root@mittsume[/]# /tmp/tmpjtqbqcly showconfig
KEYPRINT=
WORKDIR=/var/db/freebsd-update
SERVERNAME=
MAILTO=root
ALLOWADD=yes
ALLOWDELETE=yes
KEEPMODIFIEDMETADATA=yes
COMPONENTS=
IGNOREPATHS=
UPDATEIFUNMODIFIED=
BASEDIR=/
VERBOSELEVEL=stats
TARGETRELEASE=
STRICTCOMPONENTS=no
MERGECHANGES=
IDSIGNOREPATHS=
BACKUPKERNEL=yes
BACKUPKERNELDIR=/boot/kernel.old
BACKUPKERNELSYMBOLFILES=no


Missing more than a few things here...

I've actually already made a brand new starting-with-11.3 Plex jail and moved my server over to it. It's less work than figuring out these issues frankly.
 
Last edited:
Top