Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

SOLVED Cannot connect to FreeNAS using Windows XP

bys1

Neophyte
Joined
Oct 21, 2017
Messages
5
Good evening,

I am trying to setup FreeNAS on an HP ProLiant DL360 G7 server. It all worked fine until I tried connecting with Windows XP.
I have some groups&users setup, all working well, and Windows SMB sharing. With this setup, I can see the server under "Network" on both Windows 7 and Mac OS X and then connect to it as one of the users created. However, with Windows XP, I do not see the server in the Network section and can only connect by going to \\192.168.1.<someport>. Then I can try to login: a window pops up where I have to enter a username and password. All looks really good. Though, as soon as I enter my details again, the window simply pops up again and the username is suddenly prefixed by some computer name / username of the Windows XP machine. For example, "user1" turnt to "GEBRUIKE-F1727D\user1". I have found no way to solve this and I do not want to upgrade the computer to Windows 7.
How can I solve this? I am using the newest FreeNAS version.

Thanks in advance.

Sincerely, Björn
 

nightshade00013

Neophyte Sage
Joined
Apr 9, 2015
Messages
1,258
https://forums.freenas.org/index.php?threads/updated-forum-rules-4-11-17.45124/ said:
Hardware information is extremely important when diagnosing problems. This includes:
  • motherboard make and model
  • CPU make and model
  • RAM quantity
  • hard drives, quantity, model numbers, and RAID configuration
  • hard disk controllers
  • network cards
With that said I suspect a SMB version being set higher than windows xp can handle. The newer versions are more secure but not supported by earlier operating systems.
 

garm

Neophyte Sage
Joined
Aug 19, 2017
Messages
1,434
Tja Björn

The username turning to <something>\<username> is simply windows trying to resolve the domain to connect with. It’s picking up your computers hostname as it’s not a member of a directory.

It sounds like you have a version issue, look at the minimum version setting in SMB on FreeNAS, ref http://doc.freenas.org/11/services.html#smb

For XP to play nice I believe you need NT1
 

bys1

Neophyte
Joined
Oct 21, 2017
Messages
5
With that said I suspect a SMB version being set higher than windows xp can handle. The newer versions are more secure but not supported by earlier operating systems.
How can I change that to be compatible with Windows XP? And why does it add that weird prefix to the username instead of just giving a simple error?
 
Last edited:

bys1

Neophyte
Joined
Oct 21, 2017
Messages
5
Tja Björn

The username turning to <something>\<username> is simply windows trying to resolve the domain to connect with. It’s picking up your computers hostname as it’s not a member of a directory.

It sounds like you have a version issue, look at the minimum version setting in SMB on FreeNAS, ref http://doc.freenas.org/11/services.html#smb

For XP to play nice I believe you need NT1
Will look into it soon, thanks!
 

bigphil

Senior Member
Joined
Jan 30, 2014
Messages
483
You need to enable ntlmv1 auth for xp to connect to samba now. Search the forum and you'll find out how.
 

m0nkey_

Dedicated Sage
Joined
Oct 27, 2015
Messages
2,732
You need two things, set SMB minimum protocol to SMB1 and you need to enable NTLM auth.

However, you may want to consider upgrading your Windows XP machines. It's now out of support and is not receiving any more updates from Microsoft.
 

bys1

Neophyte
Joined
Oct 21, 2017
Messages
5
You need two things, set SMB minimum protocol to SMB1 and you need to enable NTLM auth.

However, you may want to consider upgrading your Windows XP machines. It's now out of support and is not receiving any more updates from Microsoft.
How exactly do I do that? I've already been searching for a way but couldn't find it out.

We are working with both Windows 7 and Windows XP and we cannot upgrade the XP machines at the moment. We have our reasons for that.
 

Redcoat

Dedicated Sage
Joined
Feb 18, 2014
Messages
1,540
How exactly do I do that? I've already been searching for a way but couldn't find it out.
Have you looked at section 11.12 of the Guide available from the top bar of the GUI?
 

dcharles

Newbie
Joined
Oct 28, 2017
Messages
1
On the current build 11.0, only NTLMv1 auth is required to enable XP machines to connect via SMB services.
 

frengo

Neophyte
Joined
Oct 13, 2019
Messages
6
Can I know how the problem was solved? This thread is not told in detail.
I use Freenas 9.2 because 11 is not on my hardware. However even just knowing in detail what needs to be changed in the settings of Freenas 11 is already something.

Can anyone please explain?

Thanks in advance.
 

frengo

Neophyte
Joined
Oct 13, 2019
Messages
6
In added.....In Freenas 9.2 GUI I don't find SMB options. I see only Windows logo near CIFS. It' s the same thing ?
 

danb35

Wizened Sage
Joined
Aug 16, 2011
Messages
11,417
It' s the same thing ?
Yes, it's the same thing. Keep in mind that you're trying to use an 18-year-old client OS, and a 6-year-old server OS. Both of these (especially the client) are ancient. And if your server hardware won't run FreeNAS 11, it probably shouldn't be running FreeNAS at all.
 

frengo

Neophyte
Joined
Oct 13, 2019
Messages
6
Ok, I agree, but only two laptops in my LAN have XP. For Freenas 11.2 I now have no chance to buy new hardware. What I need now is how to enable connections from XP to Freenas 9.2. If anyone knows ......
 
Top