Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Cannot Access FreeNAS Share

Joined
Dec 3, 2019
Messages
8
Hi,
I keep getting this message when I try to access Freenas share:-

'You do not have permission to access \\freenas\movies. contact your network administrator to request access.'

When I look at the properties in W10 it tells me I need read permissions to view the properties of the object.

I have reinstalled Freenas three times now and each time I have gone through the videos, both the UI one and the Legacy one. I have searched the forums here and seen people having the same problems. I have compared my settings to theirs that have subsequently worked, but mine have not.

I have changed settings on the W10 PC I am using. But I have now got to the point where I don't know if it is Freenas or my PC which has the problem.

Please could you point me in some kind of direction. I know it will be some simple step I have either missed or misunderstood, it always is.

Thanks in anticipation of a positive response.
 

Alecmascot

FreeNAS Experienced
Joined
Mar 18, 2014
Messages
283
This is covered in the Users Guide.
 
Joined
Dec 3, 2019
Messages
8
Hi,

I am sorry, but if it is covered I cannot find it? So I started again.

When I type in '\\freenas' I can see the folder 'Medialibrary' which I just created with by using the video. When I try to access it I get the message:-
'You do not have permission to access \\freenas\movies. contact your network administrator to request access.'
When I right click on it and go to properties I get the message:-
'You must have read permissions to view the properties of the object'
 

Alecmascot

FreeNAS Experienced
Joined
Mar 18, 2014
Messages
283
Did you read the bit about W10 and SMB2 sharing ?
 

G8One2

FreeNAS Experienced
Joined
Jan 2, 2017
Messages
152
This happened to me before, I had to go into the credential manager and add credentials for root to the windows machine. Not sure if that is the correct way to do it, but it worked for me.
 

Alecmascot

FreeNAS Experienced
Joined
Mar 18, 2014
Messages
283
So you have set "Windows" permissions for the dataset , Then in windows given everyone full control ?
 

Alecmascot

FreeNAS Experienced
Joined
Mar 18, 2014
Messages
283
 

anodos

Sambassador
iXsystems
Joined
Mar 6, 2014
Messages
5,872
Hi,
I keep getting this message when I try to access Freenas share:-

'You do not have permission to access \\freenas\movies. contact your network administrator to request access.'

When I look at the properties in W10 it tells me I need read permissions to view the properties of the object.

I have reinstalled Freenas three times now and each time I have gone through the videos, both the UI one and the Legacy one. I have searched the forums here and seen people having the same problems. I have compared my settings to theirs that have subsequently worked, but mine have not.

I have changed settings on the W10 PC I am using. But I have now got to the point where I don't know if it is Freenas or my PC which has the problem.

Please could you point me in some kind of direction. I know it will be some simple step I have either missed or misunderstood, it always is.

Thanks in anticipation of a positive response.
This typically means that your permissions are set incorrectly. Post ACLs for each path component leading up to your SMB share. For instance, if you share is "/mnt/tank/media/movies", you need to post the _full_ output (including owner and group) of
getfacl /mnt/tank
getfacl /mnt/tank/media
getfacl /mnt/tank/media/movies
 
Joined
Dec 3, 2019
Messages
8
I am going through another build and following the video as best I can with the same names. I am creating user1 and I have the email box highlighted in red with root filled in and my password filled in in the top password box. What have I done to get this autofilled?
I can save user1 if I delete the contents of the email and password boxes. But I notice on the video that these boxes are not pre filled.
Any Ideas?
 
Joined
Dec 3, 2019
Messages
8
I have been into the bits and bobs drawer. You know what its like when you are looking for the scissors and spend ages looking in the drawer and can't find them. Then you go back two days later and they are on top of everything else.

Well I had myself tied in knots with setting up FreeNAS and left it for two days. Set it up and first time it worked. Whatever mistake I was making I must have been making each time I set it up.

Thankyou everyone for your help I am a very happy chappy now.

To be fair I did think it was me all along, I just could not see the wood for the trees
 
Joined
Jan 22, 2020
Messages
2
I have been into the bits and bobs drawer. You know what its like when you are looking for the scissors and spend ages looking in the drawer and can't find them. Then you go back two days later and they are on top of everything else.

Well I had myself tied in knots with setting up FreeNAS and left it for two days. Set it up and first time it worked. Whatever mistake I was making I must have been making each time I set it up.

Thankyou everyone for your help I am a very happy chappy now.

To be fair I did think it was me all along, I just could not see the wood for the trees
Not to be a picky penelope... but what did you do differently? Can you please share for the class?
 
Top