Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

Bacula Plugin: Only Bacula-FD installed (Bacula Storage Director and Bacula Director not installed as well)

Joined
Jan 13, 2020
Messages
3
On FreeNAS-11.2-U7 I installed the "Bacula" plugin which created the jail and assigned a static IP that I specified correctly. When go into the jail shell only bacula-fd is installed. The /root/post_install.sh that the plugin runs references bacula-dir, bacula-sd, and bacula-fd and tries to start it but it does not exist in the jail.

Any idea if I am missing a step somewhere to get bacula-dir and bacula-sd installed too?
 

JoeAtWork

Newbie
Joined
Aug 20, 2018
Messages
26
if you open up a command prompt on your FN box and do "iocage console bacula-server" and cat /etc/rc.conf you will see that dir and sd were installed and told to start. I do not know why.
 

JoeAtWork

Newbie
Joined
Aug 20, 2018
Messages
26
I just did a test on FN 11.3 release and if you install it with no settings but NAT it works to the point you have 2 commands in the console to fix it. "pkg update" "pkg install bacula9-server" and while your still in the root folder "./post_install.sh"
 
Joined
Jan 13, 2020
Messages
3
Just did the install after updating to 11.3 Release and get this message (it only installs if I select NAT):


Plugin installed successfully
Install Notes:
postgresql_enable: -> YES
bacula_dir_enable: -> YES
bacula_fd_enable: -> YES
bacula_sd_enable: -> YES
The files belonging to this database system will be owned by user "pgsql".
This user must also own the server process.
The database cluster will be initialized with locale "C".
The default text search configuration will be set to "english".

Data page checksums are disabled.

creating directory /usr/local/pgsql/data ... ok
creating subdirectories ... ok
selecting default max_connections ... 100
selecting default shared_buffers ... 128MB
selecting default timezone ... America/New_York
selecting dynamic shared memory implementation ... posix
creating configuration files ... ok
creating template1 database in /usr/local/pgsql/data/base/1 ... ok
initializing pg_authid ... ok
initializing dependencies ... ok
creating system views ... ok
loading system objects' descriptions ... ok
creating collations ... ok
creating conversions ... ok
creating dictionaries ... ok
setting privileges on built-in objects ... ok
creating information schema ... ok
loading PL/pgSQL server-side language ... ok
vacuuming database template1 ... ok
copying template1 to template0 ... ok
copying template1 to postgres ... ok
syncing data to disk ... ok

Success. You can now start the database server using:

/usr/local/bin/pg_ctl -D /usr/local/pgsql/data -l logfile start
WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
LOG: ending log output to stderr
HINT: Future log output will go to log destination "syslog".
WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
CREATE ROLE
WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
CREATE DATABASE
WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
ALTER ROLE
WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
CREATE EXTENSION
WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
LOG: ending log output to stderr
HINT: Future log output will go to log destination "syslog".
WARNING: enabling "trust" authentication for local connections
You can change this by editing pg_hba.conf or using the option -A, or
--auth-local and --auth-host, the next time you run initdb.
LOG: ending log output to stderr
HINT: Future log output will go to log destination "syslog".
/root/post_install.sh: ./make_bacula_tables: not found
LOG: ending log output to stderr
HINT: Future log output will go to log destination "syslog".
/root/post_install.sh: ./grant_bacula_privileges: not found
bacula-dir does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable
/root/post_install.sh: ./grant_bacula_privileges: not found
Starting bacula_fd.
/root/post_install.sh: ./grant_bacula_privileges: not found
bacula-sd does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable
/root/post_install.sh: ./grant_bacula_privileges: not found
bacula-sd does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable
bacula-sd does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable
 
Joined
Jan 13, 2020
Messages
3
I just did a test on FN 11.3 release and if you install it with no settings but NAT it works to the point you have 2 commands in the console to fix it. "pkg update" "pkg install bacula9-server" and while your still in the root folder "./post_install.sh"
Thanks, I am just now getting back to this. I entered the jail and ran those commands. The bacula-* services are now running.

Thanks for the help. I am surprised the plugin doesn't automatically install the storage daemon and director given that they are in the /etc/rc.conf
 
Top