Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

AFP share access issue 11.2-U5 and now 11.2-U3

Joined
Feb 25, 2019
Messages
6
Thanks
0
#1
Hello..

I have a rather annoying issue..

After updating my 11.2-U3 installation to U5, my apple users suddenly stopped having access to their home-folders (requires user credentials that are checked against LDAP)..

I my afp.log i see this:

Code:
Jul 10 12:30:33.720985 cnid_metad[3716] {cnid_metad.c:632} (severe:CNID): main: no volume for path "/mnt/dsl/home/AUTH/lkf"
Jul 10 12:30:34.785017 cnid_metad[3716] {netatalk_conf.c:1822} (error:Default): unknown user: AUTH
Jul 10 12:30:34.785047 cnid_metad[3716] {cnid_metad.c:632} (severe:CNID): main: no volume for path "/mnt/dsl/home/AUTH/lkf"
Jul 10 12:30:35.814065 cnid_metad[3716] {netatalk_conf.c:1822} (error:Default): unknown user: AUTH
Jul 10 12:30:35.814097 cnid_metad[3716] {cnid_metad.c:632} (severe:CNID): main: no volume for path "/mnt/dsl/home/AUTH/lkf"
Jul 10 12:30:35.814216 afpd[9456] {cnid_dbd.c:414} (error:CNID): transmit: Request to dbd daemon (volume lkf's home) timed out.
Jul 10 12:30:35.814257 afpd[9456] {volume.c:865} (error:AFPDaemon): afp_openvol(/mnt/dsl/home/AUTH/lkf): Fatal error: Unable to get stamp value from CNID backend


Which seems to indicate an issue with the folder path.

My smb4.conf seems to be fine in regards to the volume path:

Code:
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
Load smb config files from /usr/local/etc/smb4.conf
Processing section "[filebase]"
Processing section "[homes]"
Processing section "[regnskab]"
Loaded services file OK.
Server role: ROLE_STANDALONE

[homes]
    browseable = No
    comment = Home Directories
    path = "/mnt/dsl/home/%U"
    read only = No
    valid users = %U
    veto files = /.snapshot/.windows/.mac/.zfs/
    vfs objects = shadow_copy2 catia zfs_space zfsacl fruit streams_xattr
    zfsacl:acesort = dontcare
    nfs4:chown = true
    nfs4:acedup = merge
    nfs4:mode = special
    shadow:snapdirseverywhere = yes
    shadow:format = auto-%Y%m%d.%H%M-2w
    shadow:localtime = yes
    shadow:sort = desc
    shadow:snapdir = .zfs/snapshot
    fruit:resource = stream
    fruit:metadata = stream


Does anyone have any idear with it suddenly interjects AUTH into the path??

I am getting the "can't load /usr/local/etc/smb4.conf" error on boot, but according to this its an non issue?

Any help would be appreciated! Reverting back to U3 did not solve the issue, neither did restoring the config from before the upgrade (did a save config right before the upgrade)

I have a mix of apple, linux and windows users, only the apple users seem to be affected (linux users access over NFS og and windows over samba)
 
Joined
Feb 25, 2019
Messages
6
Thanks
0
#3
No its still an issue.. Also posted on the netatalk forums, but no response yet.. What baffles me is that my afp.conf seems right, so for the life of me I can't figure why it interjects AUTH into the path.. I can run "dbd -f" on my /home dir, only on the individual user folders, and those rebuild just fine..
 
Joined
Feb 25, 2019
Messages
6
Thanks
0
#4
Having played around a bit, I can now also confirm that this behavior also occurs when using sftp, it also defaults to /mnt//dsl/home/AUTH/USERNAME
 
Joined
Feb 25, 2019
Messages
6
Thanks
0
#5
I have now resolved this issue.. It turns out that my sssd.conf file under /usr/local/etc/sssd/ for some reason was altered during upgrade.. Which resulted in my home path becoming overriden..

Old conf:
Code:
[sssd]
config_file_version = 2
full_name_format = %2$s\%1$s
re_expression = (((?P<domain>[^\\]+)\\(?P<name>.+$))|((?P<name>[^@]+)@(?P<domain>.+$))|(^(?P<name>[^@\\]+)$))
services = nss,pam
domains = AUTH

[domain/AUTH]
description = AUTH
CONTENT REDACTED FOR SECURTIY
LDAP SETTINGS
override_homedir = /mnt/dsl/home/%d/%u


So for some reason I got AUTH injected into the path as the domain name..

After adding this to my LDAP conf in the GUI:
Code:
Auxillery Parameters
override_homedir = /mnt/dsl/home/%u


It now works again!

Hope this helps someone else in the future! :)
 
Top