Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

9.10.2-U1 SAS3FLASH Version LSI 9305-8i, 9305-16i, and 9305-24i Firmware and Drivers

Status
Not open for further replies.

dkusek

Member
Joined
Mar 16, 2016
Messages
78
We have been testing with the LSI 9305-16i and 24i 12Gb/s HBA's. They come stock with firmware version 9 on them. When the FreeNAS OS sees these, it shows an alert that the firmware on the cards (Phase 9) does not match the driver on the build (looking for Phase 12).

Now, when going to use sas3flash on the FreeNAS, you consistently get errors that the NVDATA is incompatible.

In working with support at Broadcom, we were able to figure out that the version of SAS3Flash used on FreeNAS 9.10.2-U1 is out of date and needs to be updated to the most current release of that software.

I was able to upload the latest version of sas3flash and the appropriate phase 12 firmware for both of the cards to a USB and flash them through UEFI no problem. When I went to check the status in FreeNAS (again, old version of sas3flash) it showed the newly flashed cards as have FW version 00.00.00.00 and "Undetermined" NVDATA. This would then cause the FreeNAS to kernel panic and reboot.

That being said, there is a newer driver for these LSI cards at Phase 14.

I am requesting that both sas3flash get updated to the newest version and also update the driver to P14 on the build side. Is that possible at this point?

Thank you,
-Devin
 

gpsguy

Active Member
Joined
Jan 22, 2012
Messages
4,473
Please post your request on bugs.freenas.org and post the issue number in this thread.
 
Status
Not open for further replies.
Top