Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

11.2-BETA2 smartd failed to start - smartd.conf missing

Elliot Dierksen

Neophyte Sage
Joined
Dec 29, 2014
Messages
906

djseto

Member
Joined
Aug 19, 2013
Messages
29
I just upgraded to 11.2 U1 and I have this issue. Missing smartd.conf and there is no ix-smartd
 

Ericloewe

Not-very-passive-but-aggressive
Moderator
Joined
Feb 15, 2014
Messages
16,721
This should be fixed in -U2.
 

keson

Neophyte
Joined
Jan 24, 2019
Messages
10
I have just installed fresh new 11.2.U3 on HP micro server G7 and this error is there from a very beginning.
root: /etc/rc: WARNING: /usr/local/etc/smartd.conf is not readable.
 

guermantes

Member
Joined
Sep 27, 2017
Messages
177
Same here (almost).

Since fresh installing 11.2-U3 and loading config file from 11.0-U4 I have never received SMART emails although the rest of the system emails are sucessfully sent. Changes made to Services -> SMART -> edit are reflected in /usr/local/etc/smartd.conf, but there is no /etc/ix.rc.d/ix-smartd file at all. I gather that's why no emails are being sent. Not sure if I could use the line on the previous page as a template because there are so many options and switches and stuff.
 

katena

Newbie
Joined
Sep 7, 2020
Messages
2
I'm very sorry to say but this is still an issue and sincerely it should not be after such long time. Just a beginner in FreeNas, don't crack my head (kidding) but it's a thing that need to be said.
Fresh install FreeNAS-11.3-U4.1.
Tested:
1 x Raid card(obviously in HBA mode): HPE Smart Array P822 (I know, everyone will say not compatible nor recommended hardware)
3 x HBA cards: HPE H240 HBA and 2 cards with LSI 9211-8i chipset (DELL PERC H310 and Fujistu D2607-A11) both flashed to latest IT firmware 20.00.04.00-IT.
Same frustrating result:
- no presence of /etc/ix.rc.d/ix_smartd file
- file /usr/local/etc/smartd.conf is empty
- smartd is not running

From CLI:
root@freenas[~]# camcontrol devlist
<ATA KINGSTON SA400S3 B1E2> at scbus1 target 8 lun 0 (pass0,da0)
<ATA Samsung SSD 860 4B6Q> at scbus1 target 9 lun 0 (pass1,da1)
<ATA Samsung SSD 860 4B6Q> at scbus1 target 10 lun 0 (pass2,da2)
<ATA Samsung SSD 860 3B6Q> at scbus1 target 11 lun 0 (pass3,da3)
<ATA Samsung SSD 860 3B6Q> at scbus1 target 12 lun 0 (pass4,da4)
<HP iLO Internal SD-CARD 2.10> at scbus4 target 0 lun 0 (pass5,da5)

root@freenas[~]# smartctl -a /dev/da0
smartctl 7.0 2018-12-30 r4883 [FreeBSD 11.3-RELEASE-p11 amd64] (local build)
Copyright (C) 2002-18, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF INFORMATION SECTION ===
Model Family: Phison Driven SSDs
Device Model: KINGSTON SA400S37120G
Serial Number: 50026B778355B86B
LU WWN Device Id: 5 0026b7 78355b86b
Firmware Version: SBFKB1E2
User Capacity: 120,034,123,776 bytes [120 GB]
Sector Size: 512 bytes logical/physical
Rotation Rate: Solid State Device
Device is: In smartctl database [for details use: -P show]
ATA Version is: ACS-3 T13/2161-D revision 4
SATA Version is: SATA 3.2, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is: Mon Sep 7 13:57:23 2020 EEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

Same result for all the other SSDs (excluding the SD card - disabled SMART for it in Storage -> Disks -> Edit -> Enable SMART checkbox -> Unchecked)

If I manually add DEVICESCAN -a to /usr/local/etc/smartd.conf and manually start smartd daemon in CLI, surprise, smart is working.
So maybe this "bug" could finally be solved?
Regards!
 
Top