Register for the iXsystems Community to get an ad-free experience and exclusive discounts in our eBay Store.

11.1-U5 Panic at mountroot with error 2 after adding storage disc

Joined
Aug 29, 2018
Messages
3
Hello

I am looking for some hint with the following situation. I have not yet found a description of a similar case.

I started to build a home NAS system. So I installed the version 11.1-U5 of FreeNAS. At that moment my system only had one USB disk as system disc, no storage disc was installed yet. Once I got the system up and running (I had to tweak some uefi + kernel parameters), I added a hard disc drive to the system. The hard drive has no data, just an existing partition table left over from a previous test. Then I booted the machine. Booting and loading FreeNAS went fine from USB system disc until it stopped with kernel panic. Have a look at the errors screen errors in attachment.
boot sequence until kernel panic.jpg
Main errors:
Code:
Trying to mount root from zfs:freenas-boot/ROOT/default
mountroot: unable to remount devfs under /dev (error 2)
mountroot: unable to unlink /dev/dev (error 2)
panic: no init
KDB: stack backtrace:


When I unplug the disc drive (SATA), booting FreeNAS works normally just as after the initial install. I can access the web interface.

Anybody can explain me what has happened and how can I get the system running again? Eventually I foresee to run with three discs.

kind regards

Julius

My system:
ASRock J4205-ITX / Intel Apollo Lake; 16GB RAM; 16GB USB system disc, WD Red discs,
 
Joined
Aug 29, 2018
Messages
3
Not really. As I did not get a hint, I tried various zpool commands in a live FreeNAS session without result. So I decided to do a fresh install with U6. At my big astonishment I got the same result at booting as described initially. Now I suspect a problem with my Usb memory stick and will investigate in this direction.
 
Top